tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vivek Agarwal" <vive...@hotmail.com>
Subject Help with TLS
Date Thu, 10 Jan 2002 18:54:30 GMT
Hi,

  I enabled SSL/TLS on Tomcat 4.0 after installing JSSE 1.0.2.
I could successfully see the page http://localhost:8443/.

  Then I tried connecting to the tomcat server using a URL Connection
class from a Java client (I set the appropriate ssl input stream
handler system property required by JDK) which also used JSSE 1.0.2
Again i was successful in connecting, but when i turned on the debug
I saw that the connection used SSL and not TLS and also when i get a
list of supported ciphers i get SSL_XXXXXXXXXX and not TLS_XXXXXXXX.
So I cannot use a TLS cipher on the connection.

  Theoretically i should not face such a problem because the Tomcat
server and my Java client use the same JSSE1.0.2 jar files. So I
should be able to use TLS for the connection. In my Java client I
tried to explicitly set up a SSLContext with 'TLS', get a
SSLSocketFactory and set this factory on my connection, but even this
did not help.

  I am using JDK 1.3.0 on W2K.

  Any help would be much appreciated.

Thanks in advance,
Vivek





_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message