tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Paeth" <tomcat_users_maill...@fortdearborn.com>
Subject RE: Config/Startup problem contextInit() not running
Date Mon, 21 Jan 2002 22:04:36 GMT
That is a great question, how do I check since I can't find anything in a
log file?

Thanks,
Adam

> -----Original Message-----
> From: Larry Isaacs [mailto:Larry.Isaacs@sas.com]
> Sent: Monday, January 21, 2002 3:53 PM
> To: 'Tomcat Users List'
> Subject: RE: Config/Startup problem contextInit() not running
>
>
> I'll investigate for Tomcat 3.3a/3.3.1-dev.  Do you know if your
> <CustomRealm /> is being loaded, as opposed to being ignored?
>
> Cheers,
> Larry
>
> > -----Original Message-----
> > From: Adam Paeth [mailto:tomcat_users_maillist@fortdearborn.com]
> > Sent: Monday, January 21, 2002 4:10 PM
> > To: Tomcat User List
> > Subject: Config/Startup problem contextInit() not running
> >
> >
> >
> > I'm going crazy trying to figure this out...
> >
> > I've re-written a customized realm that we used for our
> > Tomcat 3.2.1 (now
> > for 3.3).  For some reason the debug messages that I've put into the
> > contextInit() method are not showing up on the console or any
> > log files.  It
> > doesn't appear that the method is running.  Can anyone tell
> > me why this is
> > happening and the best approach to fixing it?
> >
> > After getting some advice from a previous post I setup the
> > config files as
> > such:
> >
> > apps-myapp.xml
> > --------------
> > <?xml version="1.0" encoding="ISO-8859-1"?>
> > <webapps>
> >    <Context path="/myapp"
> >             docBase="webapps/myapp"
> >             debug="1"
> >             reloadable="true" >
> >               <CustomRealm />
> >               <LogSetter name="myapp_tc.log" path="logs/myapp.log" />
> >               <LogSetter name="myapp_servlet_log"
> >                          path="logs/servlet_myapp.log"
> >                          servletLogger="true"/>
> >   </Context>
> >
> > </webapps>
> >
> > modules-myapp.xml
> > -----------------
> > <?xml version="1.0" encoding="UTF-8"?>
> > <modules>
> >   <module name="CustomRealm" javaClass="myapp.tomcat.CustomRealm"/>
> > </modules>
> >
> > Thanks,
> > Adam Paeth
> >
> >
> > --
> > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> >
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>
>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message