tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis.John...@mail.sprint.com
Subject RE: Tomcat 4.0.1 and Apache 1.3.22 on NT 4.0 Server: Install/Config
Date Wed, 16 Jan 2002 23:22:35 GMT
Thanks for your reply, Rosh.

Further Questions:
(1) If both Apache and Tomcat are both running and both configured to 
port 80, which
will handle a request?  Will Apache process html requests and Tomcat 
process jsp
requests?
(2) I have Apache configured to return a custom page for 404 Error 
responses.  If an
unknown jsp request is submitted and Tomcat tries to process it, will 
Tomcat then refer
processing back to Apache to report the 404 Error?
(3) The O'Reilly page, "Installing and Configuring Tomcat"
(http://www.onjava.com/lpt/a//onjava/2001/03/29/tomcat.html)
is for "installing Tomcat as a stand-alone server".  How is the 
installation/configuration
different for running Tomcat WITH Apache?
(4) The Jyve FAQ instructions (mentioned in previous email below) says 
to install
ApacheModuleJserv.dll in "d:\apache_root\modules\" (substituting drive 
letter, etc.,
appropriately).  Is this also needed with the Apache/Tomcat 4.0.1 
install?

Thanks again for any help provided!


-----Original Message-----
From: rnavendra [mailto:rnavendra@ccnetwork.com.au]
Sent: Wednesday, January 16, 2002 3:13 PM
To: tomcat-user
Subject: Re: Tomcat 4.0.1 and Apache 1.3.22 on NT 4.0 Server:
Install/Config


I installed Tomcat as a service too (there is an option when 
installing). In you Tomcat server.xml file (found in the conf dir) you 
must change the http port to 80 instead of 8080. Now Tomcat will handle 
the JSP.

Rosh.

>>> Dennis.Johnson@mail.sprint.com 01/17/02 08:07AM >>>
(I'm a new subscriber, so please excuse this if it's a duplicate 
request.)

Question:
How to install / configure Apache and Tomcat 4.0.1 on NT 4.0 Server so 
that
both will be started at bootup and so Apache will defer appropriate
requests (e.g., jsp) to Tomcat automatically?

What I've done so far:
Running NT 4.0 Server SP 6a.  Have installed Apache Web Server 1.3.22 
(port 80)
as a service, which runs successfully.  Have installed Java 2 SDK v 
1.3.1_02.
Have also downloaded and expanded Tomcat 4.0.1 per instructions.  Have 
set
JAVA_HOME, TOMCAT_HOME, and CATALINA_HOME on NT 4.0 Server per 
instructions.

Where I've looked so far:
The closest instructions I've found as to what I'm doing are at
<http://nagoya.apache.org:8080/jyve-faq/Turbine/screen/MainMenu/question_id/693/topic_id/102/screen/DisplayQuestionAnswer/faq_id/12/project_id/2/action/SetAll>
,
which is a Jyve FAQ - "Installing Jakarta-Tomcat on Windows NT Server".  

But it
addresses the process using Apache 3.1.12 and Tomcat 3.1, and the online
documentation for Tomcat 4.0.1 says that 4.0 is significantly different 
than
3.x.

Thanks in advance for your help!


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message