tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Prideaux" <jpride...@newlifetech.com>
Subject RE: Tomcat sample application quirk with using apache
Date Fri, 04 Jan 2002 19:49:44 GMT
Yes, I'm using Tomcat 4.0.1.     It looks like I'll go back to the earlier
3.24 version unless anyone has any recommendations on getting the 4.0.1
Tomcat versions to work without any quirks with Apache.   Even though the
quirk seems to go away when I browse from a different machine, thats not
convenient for my development environment.

-----Original Message-----
From: Bin Wu [mailto:bw_it@yahoo.com]
Sent: Friday, January 04, 2002 2:44 PM
To: Tomcat Users List
Subject: Re: Tomcat sample application quirk with using apache


I have the same problem.  The apache with tomcat 4.01
responds really slow, sometimes it popups a WebApp 500
error.  I have tried tomcat 3.24 with same apache
server using mod_jk no problem.  And the
localhost:8080 in both 3.24 and 4.01 works fine.  So I
assume the problem is in tomcat webapp module.   Do
anyone have the solution?

--- Jeff Prideaux <jprideaux@newlifetech.com> wrote:
> This may be a simple problem.
>
> I followed the Tomcat instructions in the
> documentation to create the sample
> webapp (myapp) consisting of the following: one
> image, one html file, one
> servlet, and one jsp file.
>
> All is well when I run it under Tomcat.  I can
> browse to each file and
> refresh each one multiple times.
>
> When I run it with tomcat plugged into Apache, I get
> some quirks.  Note that
> I load the page and then hit the refresh button on
> the browser a few times.
>
> The html page works fine:
> http://localhost/myapp/index.html
> The servlet works fine:
> http://jeffp-desktop/myapp/hello
>
> Although, the jsp page is acting erratically.  One
> the first time I browse
> to the page, it usually comes up fine.
> http://localhost/myapp/hello.jsp
>
> But when I hit refresh on the browser sometimes the
> page locks up.
>
> Interestingly, when I browse to the same jsp page
> from a different machine
> (browser running on different machine than the
> machine running apache and
> tomcat) I can refresh all I want and it never locks
> up.
>
> Can anyone think of why I am having problems
> refreshing the jsp page when my
> browser is running on the same machine as apache and
> tomcat?
>
> Thanks in advance...
>
>
>
> --
> To unsubscribe:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands:
> <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list:
> <mailto:tomcat-user-owner@jakarta.apache.org>
>


__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message