tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Engelhart <mengelh...@earthtrip.com>
Subject Re: Tomcat, Threads and IllegalAccessError
Date Wed, 23 Jan 2002 19:36:45 GMT
Thanks but I've already tried that. Still doesn't work.  It's not a 
classloader problem I don't think but a Thread violation error of some 
sort I think because it's happening in an InnerClass called 
TheClass$ReadThread...

I'm going to download a different web container and see if I have the 
same problems to see if it's just Tomcat.

Mike
On Wednesday, January 23, 2002, at 02:22  PM, Bo Xu wrote:

>
> I am not sure, because your "3rd party library" is in
> jakarta-tomcat-4.0.1/lib/, so it will be loaded by
> "Share Classloader", and "Share Classloader" is
> "upper" than your "webapp classloader". I just
> guess this is the reason of that problem, you can
> try it by moving your "3rd party library" from
> jakarta-tomcat-4.0.1/lib/ into WEB-INF/lib(and
> it is better to keep only-one copy).
>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message