tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tamim, Samir" <Samir.Ta...@emergis.com>
Subject RE: wacky HTTPS->HTTP re-direct problem w/apache and tomcat 4
Date Mon, 21 Jan 2002 20:47:34 GMT
Hi Dave,

Do you have a special config on linux, I have problems requesting the
/examples via the connector on Solaris 8.

Did you change something, or it was straight forward as documented.

Thanks
Sam

-----Original Message-----
From: Dave North [mailto:Dave.North@signiant.com]
Sent: Monday, January 21, 2002 15:46
To: tomcat-user@jakarta.apache.org
Subject: wacky HTTPS->HTTP re-direct problem w/apache and tomcat 4


Hello all,
	I have the following config:

apache 1.3.2.2 using mod_ssl and mod_webapp
tomcat 4.0.1
RH Linux 7.1

I had successfully configured apache to talk via the warp connector to
tomcat for our JSP application.  Now I wanted to add SSL support so I
downloaded and installed mod_ssl.  No problems so far.  However, when I
go to https://myhost/myapp/ it fails because it's re-directed me to
http://myhost:443/myapp/index.jsp.  I have the same problem with the
examples.  When served from tomcat directly (in http, no problems.

I can't seem to find anything on this problem and it's driving me crazy!
:)

Snippet from my httpd.conf:

# DN for tomcat
WebAppConnection myconn warp localhost:8008
WebAppDeploy examples myconn /examples/
WebAppDeploy myapp myconn /myapp/
WebAppInfo /webapp-info

I'm just using the standard server.xml for tomcat.

Any help is MUCH appreciated.

Cheers

Dave


Dave North
SIGNIANT Inc.
Trusted Data Transfer Services
www.signiant.com
Phone: 613-761-3623
Fax: 613-761-3629
EMail: dnorth@signiant.com



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message