tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Larry Isaacs <Larry.Isa...@sas.com>
Subject RE: mod_jk not connecting: jk_open_socket, connect() failed errno = 111
Date Wed, 16 Jan 2002 12:40:52 GMT
You don't mention that you un-commented the Ajp13Connector
in your server.xml.  It's commented out by default.

Cheers,
Larry

> -----Original Message-----
> From: //chill [mailto:chill@collective3.com]
> Sent: Tuesday, January 15, 2002 7:56 PM
> To: Tomcat Users List
> Subject: mod_jk not connecting: jk_open_socket, connect() 
> failed errno =
> 111
> 
> 
> Have installed mod_jk with my Apache 1.3.19 and Tomcat 4.0.1.
> 
> Apache Loadmodule Addmodule in httpd.conf and also these lines:
> 
> JkWorkersFile /usr/jakarta-tomcat-4.0.1/conf/workers.properties
> JkLogFile     /usr/jakarta-tomcat-4.0.1/logs/mod_jk.log
> JkLogLevel    info
> JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
> 
> JkMount /*.swt ajp13 #this is for jgenerator flash file generator
> JkMount /*.jsp ajp13
> 
> I've created a worker.properties file with the following:
> 
> worker.ajp13.type=ajp13
> worker.ajp13.lbfactor=1
> worker.loadbalancer.type=lb
> worker.loadbalancer.balanced_workers=ajp13
> worker.tomcat_home=/usr/jakarta-tomcat-4.0.1
> worker.java_home=/usr/j2sdk1.4.0
> ps=/
> worker.list=ajp13
> worker.ajp13.port=8009
> worker.ajp13.host=localhost
> 
> I'm logging these errors, and Apache is giving me a 500 
> server error when I
> attempt to view a jsp page.
> [Tue Jan 15 16:28:59 2002]  [jk_connect.c (143)]: 
> jk_open_socket, connect()
> failed errno = 111
> [Tue Jan 15 16:28:59 2002]  [jk_ajp13_worker.c (196)]: In
> jk_endpoint_t::connect_to_tomcat, failed errno = 111
> [Tue Jan 15 16:28:59 2002]  [jk_ajp13_worker.c (635)]: Error 
> connecting to
> the Tomcat process.
> [Tue Jan 15 16:28:59 2002]  [jk_ajp13_worker.c (848)]: In
> jk_endpoint_t::service, send_request failed in send loop 0
> 
> I am able to connect to Tomcat using mod_webapp through 
> Apache and on port
> 8080 without it, but it doesn't seem to like mod_jk. Any 
> ideas of what I'm
> doing wrong is appreciated
> 
> Thanks
> Chris Hill
> 
> 
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> 

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message