tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Engelhart <mengelh...@earthtrip.com>
Subject Tomcat, Threads and IllegalAccessError
Date Wed, 23 Jan 2002 16:43:34 GMT
Hi,

I have a question which may come out a bit vague because I'm using a 3rd 
party library which I only have JavaDoc for but anyway  here goes.

I have built an application which I wrote a main() stub class which 
creates Threads and calls their run() method and does what it's supposed 
to do as far as processing and running correctly.

I'm trying to use Tomcat (4.0.1) as a container to be able to start and 
stop this application (because there are multiple versions based on 
clients specific requests and I want a web interface to it) so I've 
tried to build both a servlet and JSP version of this app where the 
Threads are spawned in the init() or jspInit() method (I've also tried 
doing it from the service() method).

Anyway, I get a java.lang.IllegalAccessError from my third party library 
when I try and run it from within Tomcat but as I mentioned when I run 
it from a main() plain old application it runs fine.
The vendor doesn't have any idea what's causing it because they don't 
use their software inside web containers.

Any pointers as to what is going on with this that would cause an 
IllegalAccessError when run from within a web container versus running 
inside just the main thread of an application would be greatly 
appreciated.  I'm assuming it has something to do with threading but I 
can't tell

Thanks
mIke


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message