tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From laitin...@jippii.fi
Subject Tomcat 4.0.1 http to https redirection port number problem
Date Thu, 03 Jan 2002 15:16:52 GMT
Hi!

I'm trying to configure my tomcat 4.0.1 standalone to redirect an adress 
http://localhost:8080/some/thing to an address 
https://localhost:8443/some/thing

I've made the proper changes to the server.xml and to the web.xml and 
actually the redirection happens. But when I print out information out 
from the http request it says that the port that is being used is the 
old 8080. I'm using the request's getServerPort() method.

Does anyone have an idea why the port number won't change to the 8443? 
Because of the old port number none of my pictures nor form actions 
work.

Here are the essential parts from my web.xml and server.xml:

web.xml
---
  ...
  <security-constraint>
    <web-resource-collection>
      <web-resource-name>something</web-resource-name>
      <url-pattern>/*</url-pattern>
    </web-resource-collection>
    <user-data-constraint>
      <transport-guarantee>CONFIDENTIAL</transport-guarantee>
    </user-data-constraint>
  </security-constraint>
  ...
---

server.xml
---
I uncommented this Connector from the server.xml:
<!-- Define an SSL HTTP/1.1 Connector on port 8443 -->

Thanks for everyone!


// Janne Laitinen

__
Tämän ilmaisen suomalaisen sähköpostin tarjosi http://www.jippii.fi/
Käy tutustumassa netin parhaaseen pelipaikkaan Pasimaailmaan.


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message