tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Kalucki <jktom...@kalucki.com>
Subject Can only start server in debug mode (e.g. under jdb) on Linux.
Date Thu, 24 Jan 2002 21:25:25 GMT
When I start Tomcat 4.0.1, Java starts, but does not bind to port 8080. I 
think the JVM segfaults. If I start the server with debug (jdb), everything 
works fine.

Host: RedHat 7.1 Linux, libc.so.6,  fresh install of Tomcat 4.0.1, 
JDK1.3.1_02. $JAVA_HOME and $CATALINA_HOME set correctly.

 > cd $CATALINA_HOME/bin
jakarta-tomcat-4.0.1/bin> ./startup.sh
Using 
CLASSPATH: 
/home/jk/src/jsp/jakarta-tomcat-4.0.1/bin/bootstrap.jar:/usr/java/jdk1.3.1_02/lib/tools.jar
Using CATALINA_BASE: /home/jk/src/jsp/jakarta-tomcat-4.0.1
Using CATALINA_HOME: /home/jk/src/jsp/jakarta-tomcat-4.0.1
Using JAVA_HOME:     /usr/java/jdk1.3.1_02
jakarta-tomcat-4.0.1/bin>

netstat -nl shows no listener on port 8080. The logfile is 0 bytes, and has 
been 'touched' to the current date. A few java threads hang around a while, 
then go away in about 10 seconds.

 > catalina.sh start

Same results, no dice. Yet:

jakarta-tomcat-4.0.1/bin> ./catalina.sh debug
Using 
CLASSPATH: 
/home/jk/src/jsp/jakarta-tomcat-4.0.1/bin/bootstrap.jar:/usr/java/jdk1.3.1_02/lib/tools.jar
Using CATALINA_BASE: /home/jk/src/jsp/jakarta-tomcat-4.0.1
Using CATALINA_HOME: /home/jk/src/jsp/jakarta-tomcat-4.0.1
Using JAVA_HOME:     /usr/java/jdk1.3.1_02
Initializing jdb...
 > run
run org.apache.catalina.startup.Bootstrap start
 >
VM Started: Starting service Tomcat-Standalone
Apache Tomcat/4.0.1
Starting service Tomcat-Apache
Apache Tomcat/4.0.1

At this point the demo is available, netstat -ln shows a binding to port 
8080, etc.

The run option exposes a fault:

jakarta-tomcat-4.0.1/bin> ./catalina.sh run
Using 
CLASSPATH: 
/home/jk/src/jsp/jakarta-tomcat-4.0.1/bin/bootstrap.jar:/usr/java/jdk1.3.1_02/lib/tools.jar
Using CATALINA_BASE: /home/jk/src/jsp/jakarta-tomcat-4.0.1
Using CATALINA_HOME: /home/jk/src/jsp/jakarta-tomcat-4.0.1
Using JAVA_HOME:     /usr/java/jdk1.3.1_02
./catalina.sh: line 234:  5598 Segmentation fault      $JAVA_HOME/bin/java 
$CATALINA_OPTS -classpath $CP -Dcatalina.base=$CATALINA_BASE 
-Dcatalina.home=$CATALINA_HOME org.apache.catalina.startup.Bootstrap "$@" start
jakarta-tomcat-4.0.1/bin>

Similar things happen if I try this from the command line.

Any clues as to what I'm doing wrong?

-John Kalucki
jktomcat@kalucki.com


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message