tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Ferayorni" <Andrew.Ferayo...@onsemi.com>
Subject Problem w/ Tomcat 3.3 and xerces.jar
Date Thu, 31 Jan 2002 19:48:24 GMT
Hello all,

I'm having trouble getting a servlet app to work with the Tomcat 3.3
servlet engine.

Tomcat has worked great for my servlet apps so far.  Recently, I
developed an app that uses xerces to parse XML data. If I put xerces.jar
in my CLASSPATH, tomcat starts up fine but I get a class not found error
on CoreDocumentImpl when the servlet inits (which is when it parses some
XML data).

I read many postings on this mailing list about conflicts between
Tomcat's XML parser and parsers that people are trying to use in their
apps.  I read about people editing the tomcat.sh file and putting the
path to their xerces.jar in front of Tomcat's CLASSPATH.  OK, but when I
do that, Tomcat doesn't start up.  It gets through setting up the
contexts and then dies.  I saw this same error when I originally tried
putting xerces.jar in the /jre/lib/ext folder.  My guess is that Tomcat
is failing because it is trying to use my xerces.jar classes to parse
it's XML files.

This is really giving me a headache, can anyone help???


I have the following setup:

SuSE Linux 7.2 (i386)
Apache 1.3.19 running  mod_jk
Tomcat 3.3


Thanks!
Andrew


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message