tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Luc BEAUDET <beau...@toolchest.cyber.kodak.com>
Subject Re: Errors using warp connector
Date Tue, 29 Jan 2002 11:10:52 GMT
Julien OIX a écrit :

> Donald Lee a écrit :
> >
> > Hello, I am trying to get the mod_webapp configured and have really been
> > goofing it up bigtime.  right now tomcat is inaccessible even when I place
> > the :8080 after the server name.
> > Has anybody seen this kind of error before?  I am thinking I need to look up
> > the source and recompile but I wanted to be sure that was my problem.  Kinda
> > looks like it's the least of my problems but I am just guessing here.  If
> > anybody can throw me a bone, it would be appreciated.
> >
> > Here is a section of my error_log:
> >
> > [Mon Jan 28 21:05:29 2002] [warn] Loaded DSO lib/apache/mod_webapp.so uses
> > plain Apache 1.3 API, this module might crash under EAPI! (please recompile
> > it with -DEAPI)
> > [Mon Jan 28 21:05:29 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:29 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:29 2002] [notice] Apache-AdvancedExtranetServer/1.3.20
> > (Mandrake Linux/3mdk) mod_ssl/2.8.4 OpenSSL/0.9.6b configured -- resuming
> > normal operations
> > [Mon Jan 28 21:05:29 2002] [notice] suEXEC mechanism enabled (wrapper:
> > /usr/sbin/suexec)
> > [Mon Jan 28 21:05:29 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:29 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:29 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:29 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:29 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:29 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:42 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:42 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:43 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:43 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:43 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:43 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:44 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:44 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:44 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:44 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:44 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:44 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:05:44 2002] [error] Connection "warpConnection" cannot
> > connect
> > [Mon Jan 28 21:05:44 2002] [error] Cannot open connection "warpConnection"
> > [Mon Jan 28 21:10:24 2002] [notice] caught SIGTERM, shutting down
> >
> > this is setup at the top of my httpd.conf file
> > ServerType standalone
> > ServerRoot /etc/httpd
> > ServerName lnxwebsvr
> > PidFile /var/run/httpd.pid
> > ScoreBoardFile /etc/httpd/httpd.scoreboard
> > ErrorLog logs/error_log
> > LogLevel warn
> > ResourceConfig /dev/null
> > AccessConfig /dev/null
> >
> > I have this configured at the bottom of my httpd.conf:
> >
> > LoadModule webapp_module lib/apache/mod_webapp.so
> > WebAppConnection warpConnection warp localhost:8008
> > WebAppDeploy examples warpConnection /examples/
> > WebAppDeploy Guestbook warpConnection /Guestbook/
> >
> > I am getting this in catalina.out. I am not sure what address the error is
> > referring to.
> >
> > ----- Root Cause -----
> > java.net.BindException: Address already in use
> >         at java.net.PlainSocketImpl.socketBind(Native Method)
> >         at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:452)
> >         at java.net.ServerSocket.<init>(ServerSocket.java:170)
> >         at java.net.ServerSocket.<init>(ServerSocket.java:121)
> >         at
> > org.apache.catalina.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:118)
> >         at
> > org.apache.catalina.connector.warp.WarpConnector.initialize(WarpConnector.java:477)
> >         at
> > org.apache.catalina.core.StandardService.initialize(StandardService.java:454)
> >         at
> > org.apache.catalina.core.StandardServer.initialize(StandardServer.java:552)
> >         at org.apache.catalina.startup.Catalina.start(Catalina.java:775)
> >         at org.apache.catalina.startup.Catalina.execute(Catalina.java:681)
> >         at org.apache.catalina.startup.Catalina.process(Catalina.java:179)
> >         at java.lang.reflect.Method.invoke(Native Method)
> >         at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:243)
> > Catalina.stop: LifecycleException:  This server has not yet been started
> > LifecycleException:  This server has not yet been started
> >         at org.apache.catalina.core.StandardServer.stop(StandardServer.java:526)
> >         at org.apache.catalina.startup.Catalina.start(Catalina.java:794)
> >         at org.apache.catalina.startup.Catalina.execute(Catalina.java:681)
> >         at org.apache.catalina.startup.Catalina.process(Catalina.java:179)
> >         at java.lang.reflect.Method.invoke(Native Method)
> >         at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:243)
> > Catalina.start: LifecycleException:  Error creating server socket:
> > java.net.BindException: Address already in use
> > LifecycleException:  Error creating server socket:  java.net.BindException:
> > Address already in use
> >         at
> > org.apache.catalina.connector.warp.WarpConnector.initialize(WarpConnector.java:483)
> >         at
> > org.apache.catalina.core.StandardService.initialize(StandardService.java:454)
> >         at
> > org.apache.catalina.core.StandardServer.initialize(StandardServer.java:552)
> >         at org.apache.catalina.startup.Catalina.start(Catalina.java:775)
> >         at org.apache.catalina.startup.Catalina.execute(Catalina.java:681)
> >         at org.apache.catalina.startup.Catalina.process(Catalina.java:179)
> >         at java.lang.reflect.Method.invoke(Native Method)
> >         at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:243)
> >
> > --
> > I am Microsoft of Borg. You will be assimilated.
> > Resistance is futi . . .
> >
> > GENERAL PROTECTION FAULT IN MSBORG32.DLL
> > --
> > Donald Lee (dlee20@hotmail.com)
>
> try to put the "Port" Directive like this:
>
> Port 8008
>
> hope it helps ...
>
> --
> Julien OIX
> Service Informatique de Gestion
> Tél: 02 40 99 83 65
> mail: julien.oix@presidence.univ-nantes.fr
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

Well is that because yur port 8080 is already in use.

If yu're under UNIX, try to know what is goin' on with that port

A wonderfull tools is lsof: lsof -i tcp | grep 8080 will give yu informations.

try a ps -fe | grep java to see if an older Tomcat process is runnin'.

In both cases make a kill -9 of the referenced process.

Lauch startup.sh again and enter another ps -fe to verify.

Hope this help.

Jean-Luc :O)



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message