tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Luc BEAUDET <beau...@toolchest.cyber.kodak.com>
Subject Re: mod_webapp error
Date Mon, 28 Jan 2002 14:38:19 GMT
JStanczak@vinu.edu a écrit :

> Unfortunately I did not get Apache and Tomcat connected. I found that for
> my needs just using Tomcat and removing Apache was the best option. I
> started to setup the mod_jk, but stopped when I decided to just use Tomcat
> only. For the most part I found that web app mod was just not ready for
> production. I found nothing on why it wouldn't work for me and the person
> that made it was not working on it anymore. That's just what I found out.
> This may not be the case, but like all of you I could not find any help. I
> didn't find several sources  that said jk_mod was the best option at the
> time. It was by far more reliable. I also figured that if over 50% of my
> accesses were to Tomcat then it would most likely be a greater benefit to
> bypass Apache and just access Tomcat directly. Why add that extra step of
> going through Apache to get to Tomcat. I currently have several web
> applications that I've developed running on Tomcat. Their not in production
> yet, but they should be within the month. So far I have had no problems
> with the Tomcat only setup. Well, that was the short version of what I
> discovered while trying to use the mod_webapp. But just to give you a
> picture, since I'm a professional Java developer if I can't find it already
> made with Java then I have the option of just developing it myself. Some of
> you may just be using Tomcat to run a web application that you have, but
> you may not be a Java developer.
>
> Thank You,
>
> Justin A. Stanczak
> Web Manager
> Shake Learning Resource Center
> Vincennes University
> (812)888-5813
>
>
>                     Frank Ng
>                     <flankan@pado.       To:     JStanczak@vinu.edu
>                     net>                 cc:
>                                          Subject:     mod_webapp error
>                     01/25/2002
>                     07:47 PM
>
>
>
> Dear Justin,
>
> I am sorry to bother you but I read your post on the tomcat list,
> just wondering if you ever got apache and tomcat to work?  I
> am currently having the same problem, but no one seems to have
> any idea what's going on, since you were having the same problem
> back in dec, did you ever find a solution to your problem?
>
> Any help would be great!
>
> Thanks!
> -Frank
>
> -----Original Message-----
> From: JStanczak@vinu.edu [mailto:JStanczak@vinu.edu]
> Sent: Thursday, December 13, 2001 10:04 AM
> To: Tomcat Users List
> Subject: Re: mod_webapp error
>
> Hi, I'm getting this same problem. I'm running Solaris 8 7/01 Sparc.
> I have
> Tomcat 4.0.1 and the Apache 1.3.somthing that came with the install
> of
> Solaris 8 7/01. I've tried multiple things with no luck. I even
> tried to
> compile the webapp_mod but that failed and I never got it to
> compile. I'm
> currently trying the AJP1.3. I have just downloaded it. I noticed
> you seem
> to have the same setup as me. I wanted to know if you have had any
> luck
> getting the webapp_mod to work on you machine. I'm not sure if I'm
> going to
> use Apache with Tomcat or just us Tomcat for it all. I think I'm
> going to
> ask this question on the list. Most of the stuff that I'm doing will
> be all
> Servlets anyway. If you come up with any solutions please let me
> know, it
> would be greatly appreciated.
>
> Thank You,
>
> Justin A. Stanczak
> Web Manager
> Shake Learning Resource Center
> Vincennes University
> (812)888-5813
>
>                     "Preston Hogue"
>                     <preston_hogue@ho       To:
> <tomcat-user@jakarta.apache.org>
>                     tmail.com>              cc:
>                                             Subject:     mod_webapp
> error
>                     12/09/2001 10:19
>                     PM
>                     Please respond to
>                     "Tomcat Users
>                     List"
>
> I noticed some people had the same issue in the past, I was unable
> to find
> the resolution.  Any help would be greatly appreciated.  I am
> currently
> attempting to Run Apache, Tomcat, JDK 1.3.1 on a Solaris 8 (Sun
> Installed
> Netra) and I am getting the following error:
>
> Cannot load /usr/apache/libexec/mod_webapp.so into server: ld.so.1:
> >> /usr/apache/
> >> bin/httpd: fatal: relocation error: file
> /usr/apache/libexec/mod_webapp.so:
> >> symbol __lshrdi3: referenced symbol not found
>
> Thanks,
> Preston
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

Hi.

If i well understand, yu've got pb with

SOLARIS 8 7/01
Apache 1.3.2x
Tomcat 4.0.1
mod_webapp binded to the correct Tomcat's Rel.

Well, i made exactly the same versions runnin'.

Each time i got pb for compiling and it was a real mess to go out of them.

Finally, i tetsed the following:
- Apache 1.3.22
- Tomcat 4.0.2-b2
- The correct mod_webapp for Tomcat 4.0.2-b2

I compiled all by my own with

Reading specs from /opt/sfw/lib/gcc-lib/sparc-sun-solaris2.8/2.95.3/specs
gcc version 2.95.3 20010315 (release)

jakarta-tomcat-4.0.2-b2-src.tar.gz
webapp-module-1.0.2-tc402-src.tar.gz
jakarta-ant-1.4.1-bin.tar.gz
jakarta-ant-1.4.1-optional.jar
jakarta-servletapi-4-20020116.tar.gz

Installed the following in /opt/Java_Classes:

commons-beanutils-20020116.tar.gz
commons-betwixt-20020116.tar.gz
commons-cli-20020116.tar.gz
commons-collections-20020116.tar.gz
commons-dbcp-20020116.tar.gz
commons-digester-20020116.tar.gz
commons-httpclient-20020116.tar.gz
commons-jxpath-20020116.tar.gz
commons-latka-20020116.tar.gz
commons_logging-20020116.tar.gz
commons-messenger-20020116.tar.gz
commons-modeler-20020116.tar.gz
commons-pool-20020116.tar.gz
commons-resources-20020116.tar.gz
commons-threading-20020116.tar.gz
commons-workflow-20020116.tar.gz
jaf1_0_1.zip
jakarta-struts-1.0.1.tar.gz
javamail-1_2.zip
jaxp-1_1-spec.pdf
jdbc2_0-stdext.jar
jmx-1_0-ri_bin.zip
jndi1_2_1.zip
jsse-1_0_2-gl.zip
jta-spec1_0_1.zip
junit3.7.zip
ldap-1_2_3-bin.zip
tyrex-0.9.7.0.tgz

Xerces-J-bin.1.4.4.tar.gz

and java_xml_pack-fall01.zip
in /opt

For Apache 1.3.22 i did:
#!/bin/sh

# Installation de Apache 1.3.22

# Declaration des options

cd ./apache_1.3.22 && clear

# LIBS='-lpthread' \

CC='gcc' CXX='gcc' \
CFLAGS='-D_LARGEFILE_SOURCE' \
./configure \
--verbose \
--prefix=/usr/local/Apache_EAPI \
--with-perl=/usr/local/bin/perl \
--enable-module=all \
--enable-shared=max  \
--disable-module=auth_db

 make
 make test
 make install
 make distclean

Conforming to the /usr/local/jakarta-tomcat-4.0.2-b2-src/BUILDING.txt
i made a 'compltete binary distribution' with:

ant -projecthelp

Modified the build.properties

and entered
ant dist

Last of all i build mod_webapp connector:

./configure --with-apxs=/usr/lib/Apache/bin/apxs --with-java=/usr/j2se
--with-tomcat=Dir_To_Tomcat_Home

And it's still working good.

Hope this'll help

Jean-Luc B :O)





--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message