tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Terry J Fundak <te...@tjsoftworks.com>
Subject Mod_webApp Configuration - Tomcat 4.01, Apache 1.3.22 (Darwin)
Date Sun, 20 Jan 2002 07:54:24 GMT
After a couple of weeks of really struggling with this, I need to ask
some really basic questions:

Tomcat standalone configuration is EZ, quick and works perfectly the
first time...

Using mod_webapp is a real mystery...and I'm ready to get up? I really
have tried a lot of things with little progress of getting the setup
correct.

I have attached the output from WebApp-info which is the only thing that
I have gotten to respond with any information...Sorry it is HTML because
that is what webapp-info gives...

So My Question is:

Where is mod_webapp supposed to get the "Local Deployment Path"?
    And if it isn't right where do I set it?
And if mod_webapp is NOT looking in the server.xml file in my
$JAKARTA_HOME/config/ directory, where is it looking or how do I set it
to look elsewhere?

Before someone says: Read the documentation, PLEASE I HAVE! I have read
and searched literally for days on the web. I have tried the FAQ at the
JAKARTA project which send you to the "documentation" which is
incomplete. I have read 100's and 100's of posts to this group. I tried
to read the FAQ, which do not yet exist apparently. So I know I'm not
completely crazy when I ask these questions.

And for completeness, here is my httpd.conf for a simple localhost.

...
                                         LoadModule webapp_module
libexec/httpd/mod_webapp.so
...
                                         AddModule mod_webapp.c
....

                                         WebAppConnection tomcat4 warp
localhost:8008
                                         <IfModule mod_webapp.c>
                                             WebAppDeploy examples
tomcat4_connect /warp_examples
                                             WebAppDeploy cocoon
tomcat4_connect /warp_cocoon
                                             WebAppDeploy henry
tomcat4_connect /henry
                                             WebAppInfo /webapp-info
                                         </IfModule>

At this point, I need someone who has succeeded to tell me EXACTLY what
they have done.

Thank you,

Terry J Fundak

P.S. If I get this working I will write up detailed directions and a lot
of notes about what not to do. This is what the FAQ's for TOMCAT 4.0 and
mod_webapp needs at this point.


Mime
View raw message