tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rong Li <...@cellit.com>
Subject Re: Urgent: works on TC 3.2.2, but not on TC 3.3 !!!
Date Wed, 16 Jan 2002 23:27:45 GMT
Larry Isaacs wrote:

>For Tomcat 3.3, it's not clear if you are getting one instance
>in two separate sessions or two instances being stored in
>the same session.  Can you supply a more complete test case
>so I can attempt to duplicate the problem?
>
>Note that Tomcat 3.3 is noticably faster than Tomcat 3.2.x.
>If your web application has the potential to have competing
>requests step on each other's session attributes, you are more
>likely to actually see it happen in Tomcat 3.3 than Tomcat
>3.2.2.  There isn't enough info here to say if this case
>is an example of this, or something else.
>
>Cheers,
>Larry
>
>>-----Original Message-----
>>From: Rong Li [mailto:rli@cellit.com]
>>Sent: Wednesday, January 16, 2002 5:44 PM
>>To: tomcat-user@jakarta.apache.org
>>Subject: Urgent: works on TC 3.2.2, but not on TC 3.3 !!!
>>
>>
>>I have two jsp pages with the same statement:
>><jsp:useBean id="chatBean" scope="session" 
>>class="com.cellit.cpchatbean.CPChatBean"/>
>>
>>On TC 3.2.2, only one instance was created and successfully shared. 
>>However, on TC 3.3, two instances were created, and cannot be shared.
>>
>>Anybody knows what happened? How to resolve that?
>>
>>Thanks,
>>Rong Li
>>
>>
>>
>>--
>>To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>>For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
>>Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>>
>
>--
>To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
>Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>
Hi Larry,

You are right. I made a mistake. I tried to print out the session Ids 
for those two jsp pages. They did have different Ids. So it means that 
the two jsp pages have been associated with two different sessions. But 
how? It works great under TC 3.2.2.

Here is some details.

I put ChatReceive.jsp and ChatSend.jsp in two frames within ChatMain.jsp.
In ChatReceive.jsp and ChatSend.jsp, each includes the same statement:

<jsp:useBean id="chatBean" scope="session" class="com.cellit.cpchatbean.CPChatBean"/>

Basically, I want those two pages to share the same bean instance which 
opens a socket connection with Chat Server.

I also tried to use session.set(get)Attribute() to work around the 
problem. It still does not work.

Thanx,
Rong Li


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message