tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Brand <obr...@yahoo.com>
Subject Having problems with mod_proxy and Tomcat 4.0.1
Date Sun, 06 Jan 2002 17:26:31 GMT
All,

I have installed and configured Apache 1.3.22 and Tomcat 4.0.1 on 
Solaris 8 and am having the following problems when accessing the tomcat 
instance:

Configuration:

let's say my web server is: mywebserver, and the tomcat server is: 
myappserver I have the following mapping in the apache httpd.conf:

ProxyPass /apps http://myappserver:8081/apps
ProxyPassReverse /apps http://myappserver:8081/apps

On the tomcat server.xml I do have something like:

<Connector className="org.apache.catalina.connector.http.HttpConnector"
port="8081" ...
proxyName="mywebserver"

Problem:

When accessing the following URL:

http://mywebserver/apps/examples/jsp
it is getting translated to:
http://mywebserver/examples/jsp

The apps is gone !!

Now when I am trying the same URL but with a file name, it works:
http://mywebserver/apps/examples/jsp/index.html

Same issue for any links with a path in it:
http://mywebserver/apps
is getting translated to:
http://mywebserver/index.html

If someone could help me, I would really appreciate it since I am new to Apache and Catalina
configurations.

Thanks

Olivier




_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message