tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From neil <n...@rackle.com>
Subject tomcat4/apache HTTP header problem
Date Sun, 06 Jan 2002 02:22:31 GMT
when I access a particular servlet via mod_webapp, I get an HTTP header 
"Connection: close", which prevents clients from seeing the data.

through apache:
HTTP/1.1 200 OK
Date: Sat, 05 Jan 2002 22:23:38 GMT
Server: Apache/1.3.19 (Unix) mod_ssl/2.8.1 OpenSSL/0.9.6 PHP/4.0.4pl1
Content-Type: image/jpeg
Connection: close

through Tomcat's webserver:
HTTP/1.1 200 OK
Content-Type: image/jpeg
Content-Length: 5733
Date: Sat, 05 Jan 2002 22:23:57 GMT
Server: Apache Tomcat/4.0.1 (HTTP/1.1 Connector)

I can wget the contents of the URL both ways and that works fine (I get 
the image), but I think the "Connection: close" is preventing other 
clients from getting the data (browsers display "document contains no 
data" or a broken image icon and applets throw NullPointer exceptions). 
  also, I can access other servlets and .jsps fine, so I assume that the 
container and connector are set up correctly.

the servlet is doing an HTTP GET for an image and streaming it to the 
HttpServletResponse.  I can post the code if that would help solve the 
problem.

TIA for any ideas or pointers!
neil


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message