tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Drake" <...@pobox.com>
Subject Re: Problems using same port for several services (even with different IP / hostname)
Date Thu, 10 Jan 2002 15:40:04 GMT
Contrary to your statement below, only one process may bind to the
same port (80 in this case) at the same time.

Your IIS and Inktomi servers do not both share port 80.

No, they don't.

I've never worked with Inktomi, but it's conceivable that it is
being front-ended by IIS, (via an ISAPI connector of some sort).
This would explain why you think that it is available through port 80.

Tomcat may be front-ended via IIS in a similar manner. All client
requests go to IIS, which funnels them to Tomcat via an ISAPI connector.

Instructions for setting this up may be found here:
http://jakarta.apache.org/tomcat/tomcat-3.3-doc/in-process-howto.html

Tom Drake
----- Original Message -----
From: "chris brown" <dev@reflexe.fr>
To: "tomcat-user" <tomcat-user@jakarta.apache.org>
Sent: Thursday, January 10, 2002 6:51 AM
Subject: Problems using same port for several services (even with different
IP / hostname)


| Hello,
|
| I've got to add a small Tomcat-based webapp onto a machine which already
is
| already several webservers.  One is an IIS webserver, the other is a
search
| engine (Inktomi Enterprise Search) with it's own built-in search engine.
| All must run on port 80 because that's company firewall policy, and all
must
| run on the same host because that's all the company's prepared to dedicate
| in terms of resources...
|
| So far, no problem with the other services.  The machine has been assigned
| several unique IP addresses and different names in the DNS.  A similar
setup
| has been created for the Tomcat service (a unique IP address and DNS
entry).
| Tomcat responds on this IP address and domain name correctly when the port
| is anything other than "80".  I believe that the elements <Engine>,
<Host>,
| and <Alias> (the latter is within the <Host> element) are all correctly
| set... the problem seems to be with the <Connector> element:
|
|  <Connector className="org.apache.catalina.connector.http.HttpConnector"
|   address="x.x.x.x" port="80" minProcessors="5" maxProcessors="75"
|   enableLookups="true" redirectPort="443"
|   acceptCount="10" debug="0" connectionTimeout="60000"/>
|
| My "server.xml" file is pretty standard, except that the Apache Service
for
| mod_webapp has been removed and I've changed hostnames and ports as
| appropriate.  I added the "address" argument as described in the Tomcat
| documentation, but the results I'm getting are as if this attribute was
| ignored.
|
| When checking the logs and STDOUT/STDERR, I see that when the port is 80,
| Tomcat fails to start due to an exception being thrown (the basic message
is
| that the port is in use.  This is not the case for the specified port:
it's
| as if Tomcat tried binding to a different port + ip/hostname.
|
| None of the other services intercept each other's requests erroneously -
| there doesn't seem to any conflicts with them.
|
| Am I doing something wrong?  What should I do or check, and how can I make
| all these services work together correctly?
|
| Thanks,
| Christopher Brown
|
|
|
| --
| To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
| For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
| Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
|
|
|


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message