tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tulan W. Hu" <t...@lucent.com>
Subject Re: apache 1.3.22 + tomcat 4.0.1 + webapp 1.0.1
Date Tue, 15 Jan 2002 22:36:41 GMT
I just found the answer on my own question. However, it brought up another
question.
It expects I enter http://myhost.com:5000/examples/ instead of
http://myhost.com:5000/examples.  What do I need to do let it understand
http://myhost.com:5000/examples?

----- Original Message -----
From: "Tulan W. Hu" <twhu@lucent.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Tuesday, January 15, 2002 3:43 PM
Subject: apache 1.3.22 + tomcat 4.0.1 + webapp 1.0.1


> Sorry if the same question was asked before, but I just could not
> find the answer I need. I'm wondering what was missed in my steps and
> why my apache server did not pass the information to tomcat server.
>
> I am on Solaris 8 platform with gcc 2.95.3.
> My apache 1.3.22 built with the following:
> $ configure --with-port=5000 --prefix=$HOME/apache-tomcat \
>         --enable-module=so --enable-module=most --enable-rule=SHARED_CORE
> $ make;make install
>
> It works when I run http://myhost.com:5000
>
> Tomcat runs ok on http://myhost.com:8080 too.
> CATALINA_HOME=$HOME/tomcat.
>
> I download the webapp1.0.1 and run
> $ support/buildconf.sh --with-apxs=$HOME/apache-tomcat/bin/apxs
> $ configure --with-apxs=$HOME/apache-tomcat/bin/apxs \
>         --with-tomcat=$HOME/tomcat --enable-debug
> $ make #successfully build mod_webapp.so under the apache1.3 directory as
>     the document said.
>
> I copied mod_webapp.so to $HOME/apache-tomcat/libexec and added
> the following lines to the httpd.conf.
> LoadModule webapp_module libexec/moe_webapp.so
> AddModule mod_webapp.c # my httpd.conf does not have any other AddModule
> line.
> ServerName myhost.com
> ...
>         WebAppConnection warpConnection      warp  myhost.com:8008
>         WebAppInfo      /webapp-info
>         WebAppDeploy     examples  warpConnection  /examples/
>
> $ $HOME/apache-tomcat/bin/apachectl configtest # told me Syntax OK
>
> I have changed the 'localhost' in the server.xml file to 'myhost.com'.
> Both $CATALINA_HOME/bin/startup.sh and $HOME/apache-tomcat/apachectl
start,
> but I just cannot access http://myhost:5000/webapp-info.
>
> The apache error file tells me that $APACHE_HOME/htdocs/webapp-info does
> not found instead of passing it to the tomcat server.
>
> What was missed from my tasks?
>
> Furthermore, I got the following error message in the
> tomcat/logs/apache*.txt when
> I shutdown tomcat.
> 2002-01-15 12:47:22 [org.apache.catalina.connector.warp.WarpConnection]
> Exception on socket
> java.io.IOException: Premature packet header end at
>
org.apache.catalina.connector.warp.WarpConnection.recv(WarpConnection.java:2
> 37) at
>
org.apache.catalina.connector.warp.WarpRequestHandler.handle(WarpRequestHand
> ler.java:112) at
>
org.apache.catalina.connector.warp.WarpConnection.run(WarpConnection.java:19
> 4)
>         at java.lang.Thread.run(Thread.java:484)
>
> Any ideas?
>
> Thanks in advance!
> Tulan


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message