tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Eade" <>
Subject Re: Missing Step in deployng TDk app?
Date Tue, 01 Jan 2002 22:25:26 GMT
From: "Ivo Zivkov" <>
To: <>
> I have a question about deploying the application.
> I am using the latest Turbine TDK with Tomcat 4.0.1 on Linux. After
> successfully building the sample 'newapp' in the turbine TDK, tomcat
> reposted "Not fond error 404' to the URL:
> http://localhost:8080/newapp/servlet/newapp, even though I have correctly
> set CATALINA_HOME variable. I can verify that TOMCAT is running properly,
> because id displays its information when browser pointed to
> http://localhost:8080 <http://localhost:8080/> . The only way I could get
> to work is by making a link from the TDK directory:
> $SOME_TDK_HOME/webapps/newapp
> to the tomcat directory:
> $CATALINA_HOME/webapps/newapp
> I could then access the application using the URL
> http://localhost:8080/newapp/servlet/newapp.
> Was this step not supposed to be made automatically by the build process?
> there anything special to be done to  make tomcat find the application. I
> could not find anything that links the TDK application to the tomcat
> directory.
> Any help would be greatly appreciated.
> Regards,
> Ivo Zivkov

You would probably get a better response from the turbine-user
mailing list.

The tdk comes with it's own tomcat (4.0b6 I think) and it should
fire up correctly if you use the in /tdk/bin with
CATALINA_HOME set to /tdk

If you want to use tomcat 4.01 installed elsewhere you need to
copy webapp/newapp over to the 4.01 webapp directory or
use the link that you are already using.



To unsubscribe:   <>
For additional commands: <>
Troubles with the list: <>

View raw message