tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Ong" <tk...@bass.com.my>
Subject Re: Problem when creating mod_webapp under hpux11
Date Tue, 22 Jan 2002 12:15:53 GMT
thanks jeffrey, hope to get the file from u soon .....


----- Original Message -----
From: "PELOQUIN,JEFFREY (Non-HP-Boise,ex1)" <jeffrey_peloquin@non.hp.com>
To: "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
Sent: Tuesday, January 22, 2002 8:12 PM
Subject: RE: Problem when creating mod_webapp under hpux11


> Jeff,
>
> the problem you are experiening results from the fact the Korn shell on
> HP-UX does not keep zero length strings in memory as far as I can tell,
> MYVAR = "" is null for all practical purposes. The configure file sets a
> number of variables to "" for one purpose or another.  However then the
> configure file tries to use these variables in test statements, which is
why
> you get the /usr/bin/test[7]: test: Specify a parameter with this command
> errors.  I am currently trying to rewrite the file and others for HP-UX.
>
> I have had mod_webapp working for the past five days and will send it to
you
> in a separate email.
> Anybody else want it?
>
> Jeff
>
> -----Original Message-----
> From: Jeff Ong [mailto:tkong@bass.com.my]
> Sent: Tuesday, January 22, 2002 1:58 AM
> To: Tomcat Users List
> Subject: Re: Problem when creating mod_webapp under hpux11
>
>
> Anyone own the mod_webapp for hpux11? can you please send it to me if you
> dont mind?
>
>
> ----- Original Message -----
> From: "Jeff Ong" <tkong@bass.com.my>
> To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> Sent: Tuesday, January 22, 2002 4:52 PM
> Subject: Problem when creating mod_webapp under hpux11
>
>
> > Hi all,
> >
> > i am currently try to integrate tomcat with apache. I am using tomcat
> 4.0.1
> > and apache 1.3.22. Both of the apache and tomcat run smoothly. When i
surf
> > to port 80 and 8080, both gave me the expected result.
> >
> > However, when i tried to create mod_webapp, it always hangs in a
process.
> >
> >
> > # ./configure --with-apxs=/usr/local/apache/bin/apxs
> > loading cache ./config.cache
> > checking for test... /usr/bin/test
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for true... /usr/bin/true
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for echo... /usr/bin/echo
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for grep... /usr/bin/grep
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for cat... /usr/bin/cat
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for sed... /usr/bin/sed
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for ln... /usr/bin/ln
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for rm... /usr/bin/rm
> > checking host system type... hppa1.1-hp-hpux11.00
> > checking for sources directory... /var/jeff/webapp-module-1.0-tc40
> > checking for targets directory... /var/jeff/webapp-module-1.0-tc40
> >
> > C-Language compilation tools
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for ar... /usr/bin/ar
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for ranlib... /usr/bin/ranlib
> > checking for gcc... gcc
> > checking whether the C compiler (gcc  ) works... yes
> > checking whether the C compiler (gcc  ) is a cross-compiler... no
> > checking whether we are using GNU C... yes
> > checking whether gcc accepts -g... yes
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking for gcc... /opt/gcc/bin/gcc
> > checking whether /opt/gcc/bin/gcc and cc understand -c and -o
together...
> > yes
> > checking how to run the C preprocessor... /opt/gcc/bin/gcc -E
> > checking for debug build... no
> >
> > JAVA-Language compilation tools
> > checking for java support... no
> >
> > API documentation generation
> > checking for C API documentation... no
> > checking for Java API documentation... no
> >
> > Target web-server
> > checking for Apache apxs... yes
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> > checking target module... apache-1.3
> > /usr/bin/test[7]: test: Specify a parameter with this command.
> >
> > Finishing up
> > checking for APR compilation flags... /usr/bin/test[7]: test: Specify a
> > parameter with this command.
> > ok
> > (IT ALWAYS HANGs HERE !!!!!!!!)
> >
> >
> > anyone know what is happening? I have tried to compile
> > "webapp-module-1.0.1-tc401-src.tar.gz" and
> > "webapp-module-1.0.1-tc40-src.tar.gz" but both of them gave me same
> > problems.
> >
> >
> >
> > --
> > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> >
>
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message