tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Bazell" <baz...@home.com>
Subject Examples run but my servlets won't run under 4.0.1
Date Wed, 02 Jan 2002 13:38:42 GMT
I have installed tomcat 4.0.1 on my redhat 7.1 system.  I can successfully
run the example servlets and jps's.  I wrote my own example helloworld
servlet and deployed it using ant.  I installed ANT and created the
suggested directory structure.  I then wrote a sample servlet and ran ant to
compile and deploy the servlet.  However, when I try to access it as
http://localhost:8080/sample/servlet/sampleServlet  I get a 404 error.  I
then copied the HelloWorldExample servlet that came with tomcat to my own
directory and ran ant on it.  Tomcat stores the original java file and the
class file in webapps/examples/WEB_INF/classes.  When I  deploy my own
version it ends up in a directly that is exactly parallel to where tomcat
has it.  But when I try to access it as above I still am locked out.

This is probably a problem with my web.xml file.  I am trying to set
<sevlet-name> and <servlet-class> and such.  The web.xml for the examples
that come with tomcat don't define these but rather use <filter>.

I would appreciate any help in the configuration problem.

Thanks,

Dave


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message