tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Vargas" <advar...@cis.com.ph>
Subject Re: Problem with Tomcat 4.0.1 installer: Cannot find JDK!
Date Wed, 02 Jan 2002 03:26:53 GMT
Ion,
Yup! This certainly worked! I just had to add a string value:
CurrentVersion - 1.4 to both the JDK and the JRE keys.  Thanks a lot for
your help.

William,
Try adding a CurrentVersion string value to the
HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Runtime Environment key.
Following are my registry entries (they might help):

HKLM/SOFTWARE/JavaSoft/Java Development Kit
CurrentVersion = "1.4"
HKLM/SOFTWARE/JavaSoft/Java Development Kit/1.4
JavaHome = "C:\windows\jdk143"
MicroVersion = "0"
HKLM/SOFTWARE/JavaSoft/Java Development Kit/1.4.0 beta3
JavaHome = "c:\windows\jdk143"
MicroVersion = "0"

HKLM/SOFTWARE/JavaSoft/Java Runtime Environment
CurrentVersion = "1.4"
HKLM/SOFTWARE/JavaSoft/Java Runtime Environment/1.4
JavaHome = "C:\Program Files\Java\j2re1.4.0-beta3"
MicroVersion = "0"
RuntimeLib = "C:\Program Files\Java\j2re1.4.0-beta3\bin\client\jvm.dll"
HKLM/SOFTWARE/JavaSoft/Java Runtime Environment/1.4.0 beta3
JavaHome = "C:\Program Files\Java\j2re1.4.0-beta3"
MicroVersion = "0"
RuntimeLib = "C:\Program Files\Java\j2re1.4.0-beta3\bin\client\jvm.dll"

Anton Vargas
Technical Specialist
CIS, Inc.

http://hits4pay.com/members/index.cgi?prophet
http://www.onedollaremail.com/?ref=15752
http://www.dynamicsms.com.au/intro.asp?ref=09175209396&refc=382
http://www.lunch4free.com/cgi-bin/refer?credit=advargas=cis.com.ph
----- Original Message -----
From: "Ion LarraƱaga" <ilarra@s21sec.com>
> Subject:  RE: Problem with Tomcat 4.0.1 installer: Cannot find JDK!
> The Tomcat 4.0.1 installer for Windows uses register entries to detect the
> JDK installation directory. Check the value of CurrentVersion under
> HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Development Kit. For instance,
in
> my computer I have 1.4. Then, check JavaHome under
> HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Development Kit/1.4 (in my
case),
> which must point to the java directory. The error you report seems to
> happen
> when the installer is unable to find the current version value.
>
> Hope it helps
>
> Ion

----- Original Message -----
From: "William Tillotson" <wrjt79@yahoo.co.uk>
Hi.

I too have experienced the same problem trying to get
Tomcat 4.0.1 to install on Windows when i *do* have a
valid Sun SDK (d:\jdk1.3.1_02). I have already checked
the registry as I suspected that this is where the
Tomcat installer is looking and the relevant entries
are there - yet i am still getting the same error
message from the tomcat installer as per the orginal
poster of this thread. The difference is that I am
using NT4SP6a so are there any other registry entries
i should be looking for?


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message