tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Tillotson <wrj...@yahoo.co.uk>
Subject RE: Problem with Tomcat 4.0.1 installer: Cannot find JDK!
Date Sat, 29 Dec 2001 14:37:35 GMT
Hi.

I too have experienced the same problem trying to get
Tomcat 4.0.1 to install on Windows when i *do* have a
valid Sun SDK (d:\jdk1.3.1_02). I have already checked
the registry as I suspected that this is where the
Tomcat installer is looking and the relevant entries
are there - yet i am still getting the same error
message from the tomcat installer as per the orginal
poster of this thread. The difference is that I am
using NT4SP6a so are there any other registry entries
i should be looking for?

for reference here are my registry entries:-

HKLM/SOFTWARE/JavaSoft/Java Development Kit
CurrentVersion = "1.3"
HKLM/SOFTWARE/JavaSoft/Java Development Kit/1.3
JavaHome = "D:\jdk1.3.1_02"
MicroVersion = "1"
HKLM/SOFTWARE/JavaSoft/Java Development Kit/1.3.1
JavaHome = "D:\jdk1.3.1_02"
MicroVersion = "1"
HKLM/SOFTWARE/JavaSoft/Java Development Kit/1.3.1_02
[no entries - aside from default]

I have tried entering the JavaHome and Microversion
keys to:-
HKLM/SOFTWARE/JavaSoft/Java Development Kit/1.3.1_02
with no effect, and also amended the CurrentVersion
key to "1.3.1_02" again with no luck.

Any other suggestions?

TIA

William
-------------------------------------------------------
From: Ion LarraƱaga 
Subject: RE: Problem with Tomcat 4.0.1 installer:
Cannot find JDK! 
Date: Fri, 28 Dec 2001 00:52:23 -0800 

The Tomcat 4.0.1 installer for Windows uses register
entries to detect the
JDK installation directory. Check the value of
CurrentVersion under
HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Development
Kit. For instance, in
my computer I have 1.4. Then, check JavaHome under
HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Development
Kit/1.4 (in my case),
which must point to the java directory. The error you
report seems to happen
when the installer is unable to find the current
version value.

Hope it helps

Ion


__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message