tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Ferreira" <carlos.ferre...@gilem.com>
Subject Re: Problems getting webapp module to work with apache 1.3 on windows
Date Mon, 17 Dec 2001 21:51:12 GMT
there's an error in your server.xml:

<Context path="site" docBase="/" debug="0"/>

should be:

<Context path="site" docBase="site_dir_located_under_webapps" debug="0"/>



----- Original Message -----
From: "Pritpal Dhaliwal" <pspirte@ucdavis.edu>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Friday, September 14, 2001 6:49 AM
Subject: Problems getting webapp module to work with apache 1.3 on windows


> Hi,
>
> My environment is:
> Win2k advanced server
> apache 1.3.20
> tomcat 4.0.1
> webapp module
>
> I am trying to do the following:
>
> In httpd.conf:
> WebAppConnection conn      warp  localhost:8008
> <VirtualHost IP>
>     ServerName myhost
>     ......
> WebAppDeploy     site  conn  /
> ......
>
> </VirtualHost>
>
> In server.xml I have:
>
> blah ......
>
>
>  <!-- Define the default virtual host -->
>       <Host name="myhost" debug="1"
appBase="C:/www/desiest.bachansoft.com"
> unpackWARs="true">
>         <!-- I just want a root web app right now -->
>           <Context path="site" docBase="/" debug="0"/>
>       </Host>
>
> blah ......
>
>
> My log file says apache_log in tomcat logs
> ( size: 54MB, yes 54 MB in less than a minute):
> 2001-12-15 13:10:48
> [org.apache.catalina.connector.warp.WarpConfigurationHandler] Cannot find
> "C:\Programs\Tomcat4.0\webapps\site" for appl. "site" host
> "desiest.bachansoft.com"
> #this line was repeated few thousand times
> 2001-12-15 13:10:48
> [org.apache.catalina.connector.warp.WarpConfigurationHandler] Error
> deploying web application "site" under <http://myhost:80/>
>
> my web.xml is:
> <?xml version="1.0" encoding="ISO-8859-1"?>
>
> <!DOCTYPE web-app
>     PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
>     "http://java.sun.com/dtd/web-app_2_3.dtd">
> <web-app>
> <error-page>
> <error-code>404</error-code>
> <location>/index.jsp</location>
> </error-page>
> </web-app>
>
>
> What am i doing wrong here?
>
> any help will be appreciated.
>
> Regards,
> Pritpal Dhaliwal
>
>
>
>
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message