tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Haas" <h...@mco.edu>
Subject Re: Prob loading mod_webapp on Solaris 8.
Date Thu, 29 Nov 2001 18:48:22 GMT

webapp binary didn't work for me either .. on a Sparc / Solaris 8 / Apache ... 
I down loaded the  webapp 101 src  and compiled it, 
it works ok.   Really not that hard of a thing to do .. 

If you don't have .. 
gcc and autoconf, automake, cvs are all on your Solaris 8
Companion CD.    I had to download and make a newer libtool from 
somewhere(search via yahoo.com)    

After that .. pretty much a breeze  ..   I had to do a
ln -s httpsd  httpd  as the scripts search for httpd in apache directory
   
#!/bin/sh
#
#
JAVA_HOME=/usr/java
export JAVA_HOME
TOMCAT_HOME=/usr/local/httpd/tomcat401
export TOMCAT_HOME
#
#  note path  sfw  Gnu automake etc.. 
PATH=/opt/sfw/bin:/usr/ccs/bin:$PATH
export PATH
#
#  this will build new configure file 
# support/buildconf.sh
#
./configure  --with-apxs=/usr/local/apacheraven/bin/apxs
#
# after configure runs ok  just do make .. then copy module to apache  libexec  
# make




Bye,
Scott


~~~~~~~~~~~~~~~~~~~~~~~~~~~
Scott Haas
Advanced Technologist
Center for Creative Instruction
ph 419-383-7462    fax 7498

Medical College of Ohio
3000 Arlington Ave
Toledo, OH 43614

http://www.mco.edu/cci

~~~~~~~~~~~~~~~~~~~~~~~~~~~

>>> brunton@dweeb.turner.com 11/29/01 11:55AM >>>
Matt Goyer wrote:
> 
[..snip..]
> 
> I then get:
> 
> Syntax error on line 206 of /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/libexec/mod_webapp.so into server:
> ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file
> /usr/local/apache/libexec/mod_webapp.so: symbol ap_table_get: referenced
> symbol not found
> 
> What am I missing?
> 
> Can anyone get mod_webapp working on Solaris 8?? If some has.. If you
> could post a quick install guide of what you did I'd appreciate that.
> 


 I got it working on Solaris 8 x86. Went back to mod_jk, but that's
another story. The ap_table_get function is part of the Apache code and
not the mod_webapp stuff. Are you sure that Apache is built to support
DSO libs? 


-- 
Steve Brunton   <brunton@dweeb.turner.com>  Phone: 404-827-2756
Chief Engineer Enterprise Systems    One CNN Center, Atlanta GA
CNN Internet Technologies          ICBM: 84W 23' 45" 33N 45' 29"
<*> Someday, we'll look back on this, laugh nervously and change the
subject. <*>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message