tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan E. Markovic" <i...@sculptlight.com>
Subject ClassFormatError help!
Date Tue, 27 Nov 2001 14:41:52 GMT
I checked the archives and there was nothing that was suggested that 
I haven't already tried, so I thought I would send an e-mail.

I have just upgraded to jdk 1.3.1 and to Tomcat 3.3 and Ajpv13 and I 
can't get my packages to load correctly. All my code is in .jar files 
in the correct locations. Tomcat finds the .jar files and executes my 
BootUpServlet which calls some code in a package (com/vlm/vs/) and 
that is when the error is generated.

2001-11-27 14:33:27 - Ctx(/servlets/VS) : Loading 1 BootServlet
(1) Start BootServlet
2001-11-27 14:33:28 - LoadOnStartupInterceptor: cannot load servlet 
name: BootServlet - java.lang.ClassFormatError: 
com/vlm/vs/UserManager (Illegal Variable name "<return>")
         at java.lang.ClassLoader.defineClass0(Native Method)
         at java.lang.ClassLoader.defineClass(ClassLoader.java:486)
         ........

I re-compiled all of my code using the latest JDK that I have on OS-X 
(1.3) and it still fails. I moved all the .jar files around and still 
no luck. This ran without any problems under the old configuration. 
It's managing to load and run my BootServlet but won't load anything 
in the .jar that contains my package. I have checked and 
double-checked and the.jar is not corrupt. I have uploaded it 
numerous times, still no luck.

Does anyone have any ideas please?

I v a n ...
-- 
Ivan Markovic
SculptLight
http://www.sculptlight.com
(+353) 87 2939256
(+353) 1 2982205

114 Lower Churchtown Rd,
Dublin 14,
Ireland.

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message