tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Falko Braun" <falko.br...@flow-motion.de>
Subject Invalid virtual host name on WebAppDeploy
Date Fri, 16 Nov 2001 08:51:18 GMT
I did the same configurations like mentioned below. But I get:
Invalid virtual host name

for the following line in httpd.conf:
WebAppDeploy examples conn /examples

But I did not configure any Virtual Host.


-----Original Message-----
From: Lin, Zhongwu [mailto:Zhongwu_Lin@AFCC.com]
Sent: Freitag, 16. November 2001 04:41
To: 'Tomcat Users List'
Subject: Trouble connecting Apache 1.3 & Tomcat 4 w/ mod_webApp for
window NT


I can't make Apache 1.3 & Tomcat 4 w/ mod_webApp to work.

This is what I do(follow install guide):

1) copy mod_webapp.so and libapr.dll to directory
    <apache install dir >\modules
2)edit httpd.conf like this

ServerName localhost
LoadModule webapp_module modules/mod_webapp.so

WebAppConnection conn warp localhost:8008
WebAppDeploy examples conn /examples

3) my  tomcat 4 has server.xml like this:

 <!-- Define an Apache-Connector Service -->
  <Service name="Tomcat-Apache">

    <Connector className="org.apache.catalina.connector.warp.WarpConnector"
     port="8008" minProcessors="5" maxProcessors="75"
     enableLookups="true"
     acceptCount="10" debug="0"/>

    <!-- Replace "localhost" with what your Apache "ServerName" is set to
-->
    <Engine className="org.apache.catalina.connector.warp.WarpEngine"
        name="Apache" defaultHost="localhost" debug="0" appBase="webapps">

      <!-- Global logger unless overridden at lower levels -->
      <Logger className="org.apache.catalina.logger.FileLogger"
              prefix="apache_log." suffix=".txt"
              timestamp="true"/>

      <!-- Because this Realm is here, an instance will be shared globally
-->
      <Realm className="org.apache.catalina.realm.MemoryRealm" />

    </Engine>

  </Service>

4) start tomcat 4 and then apache, I can see apache home on port 80 and
tomcat home on port 8080 like this
http://localhost/
http://localhost:8080
http://localhost:8080/examples

but the following
http://localhost/examples

give me error of "page not found"


any idea why????


any help would be greatly appreciated


John








> -----Original Message-----
> From:	David Smith [SMTP:dns4@cornell.edu]
> Sent:	Thursday, November 15, 2001 4:04 PM
> To:	Tomcat Users List
> Subject:	Re: Trouble connecting Apache 1.3 & Tomcat 4 w/ mod_webApp
>
> I'm guessing you changed the port for the Connector statement in the
> Tomcat-Apache service of server.xml to 9090?  If so, that's correct.  If
> not,
> try using 8008 instead.
>
> The second WebAppConnection line isn't needed unless it's connecting to a
> different machine and/or port.  The way your config is below, there should
>
> only be one with both WebAppDeploy lines referencing it.  This might be
> the
> source of your error.
>
> Good luck and hope this helps some.
>
> --David Smith
>
> On Thursday 15 November 2001 12:09 pm, you wrote:
> > FreeBSD, Tomcat 4, Apache 1.3.19
> >
> >
> > Here's my config;
> >
> > Alias /myapp "/usr/local/jakarta-tomcat-4.0/webapps/myapp/"
> > WebAppConnection tomcat4      warp  localhost:9090
> > WebAppDeploy     myapp  tomcat4  /myapp
> > WebAppConnection conn      warp  localhost:9090
> > WebAppDeploy     examples  conn  /examples
> >
> >
> > Here's the result from the apache error log;
> >
> > [Thu Nov 15 10:40:00 2001] [error] Cannot receive handshake WARP packet
> > [Thu Nov 15 10:40:00 2001] [error] Cannot read packet
> > (pr_warp_config.c:139) [Thu Nov 15 10:40:00 2001] [error] Cannot
> configure
> > connection "tomcat4" [Thu Nov 15 10:40:00 2001] [error] Cannot receive
> > handshake WARP packet [Thu Nov 15 10:40:00 2001] [error] Cannot read
> packet
> > (pr_warp_config.c:139) [Thu Nov 15 10:40:00 2001] [error] Cannot
> configure
> > connection "tomcat4"
> >
> > Might this be an error with compiling?
> >
> >
> >
> >
> > --
> > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message