tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Morsberger <davidmorsber...@home.com>
Subject Re: mod_jk.so kills apache 1.3.19 on tru64 v5.1
Date Sat, 10 Nov 2001 01:35:19 GMT
Nik,

We had the same behavior of disappearing apache with no core files. The
symbol error was reported when I did a "apachectl configtest"

> From: "Nikola Milutinovic" <Nikola.Milutinovic@ev.co.yu>
> Organization: EPS Elektrovojvodina
> Reply-To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> Date: Fri, 9 Nov 2001 14:22:44 +0100
> To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> Subject: Re: mod_jk.so kills apache 1.3.19 on tru64 v5.1
> 
>> I was able to get mod_jk to load on tru64 4.0f. The problem was apache was
>> not built with -pthread and it could not resolve the pthread symbols in
>> mod_jk.
>> 
>> I built mod_jk with -pthread. (jni required it.)
>> 
>> I modified all the apache Makefiles to add -pthread in the CXXFLAGS
>> variable. 
>> 
>> Rebuilt apache and everything loaded.
> 
> Lucky you. My version of mod_jk wouldn't complain on missing symbols, but it
> would just kill Apache. No core, no message, nothing. I can't remember if I
> build it with -pthread option or not.
> 
> I tried to make it work for Apache2 which is definitely multithreaded, but
> there was also a no-go situation.
> 
> Thanks for advice.
> 
> Nix.


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message