tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bin.Hu...@ReadRite.com
Subject FW: Please help on integrating Tomcat 4.0/Apache1.3.20
Date Thu, 01 Nov 2001 19:15:19 GMT



> Hi, Everyone
> 	I really need your help.
> 
> 	I am new with tomcat/Apache. Recently I am trying to set up these
> system on my PC (NT 4.0 workstation) for development of some projects and
> finally will move everything to a server (most likely W2K).  Because it is
> for development purpose, I'd like to place all my JSP, web pages, servlets
> into a special directory, say D:/exp.  Because I am new for this, I
> downloaded "jakarta-tomcat-4.0.exe" and
> "apache_1.3.20-win32-no_src-r2.msi" directly without any background on
> previous release.
> 
> 	I installed Apache first and then Tomcat.  Here is what I did:
> 
> 1) Add a context to include new path to direct to my exp folder, meanwhile
> keep the default examples.
> 	edit server.xml file by add a context to Tomcat-standalone service:
> 
> 	<context path="/exp" docBase="D:\exp"
> 	.......................
> 	/context>
> 
> 	and add an engine to Tomcat-Apache service:
> 
> 	<Engine className="org.apache.catlina.connector.warp.WarpEngine"
> name="Apache" debug="0" appBase="D:\exp"
> 	.................................................
> 	</Engine>
> 2) downloaded "webapp-module-1.0-tc40-windows.zip" and unzipped
> 
> 3) copied mod_webapp.so and libapr.dll to the mdules directory in apache
> 
> 4) Edit the Apache conf file as follows:
> 	A. add line" LoadModule webapp_module modules/mod_webapp.so" below
> all commented lines of "LoadModule...."
> 	B. add line" AddModule mod_app.c" below all commented lines of
> "AddModule....."
> 	C. run the configure test and can not pass, therefore I commented
> out the line"AddModule mod_app.c" and run the test again, 
> 	the syntax OK;
> 	D. uncomment the ServerName as "ServerName 165.85.221.41
> 	E. at the end of file, add:
> 		WebAppConnection warpConnection  warp localhost:8008
> 		WebAppDeploy     examples	warpConnection /examples 
> 		WebAppDeploy     D:/exp          warpConnection /exp
> 	save, restart tomcat and apache.
> 
> 5)Here are the test run results/problems:
> 
> 	A. if I call localhost:8080, all JSp and servlet in the examples
> works fine from both host 
> 		PC and guest PC, the files in D:\exp are readable.
> 
> 	B. if If I call localhost/examples (make request form apache)
> without 
> 		the line "WebAppDeploy     exp          warpConnection /exp"
> in apache conf file
> 
> 		For host PC, all servlets therein works fine but JSP do not
> go through 
> 				(error: the system cannot find the path
> specified)
> 		However, for guest PC, the first request for servlet is fine
> but since then the
> 			 server  never reply any more request
> 
> 	C. if I add the line "WebAppDeploy     D:/exp
> warpConnection /exp" to the end of 
> 		the conf file, the host PC become freeze (very slow for
> every program) that I 
> 		have to reboot the PC.
> 
> 	Attached are my server.xml file and conf file. I'll appreciate if
> you can give some help to solve the problems.
>  <<server.xml>>  <<httpd.conf>> 
> 
> 
> Regards,
> 
> Bin Huang
> 
> 
> 
> 	

Mime
View raw message