tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cracauer, David D." <dcraca...@vue.com>
Subject RE: Mod_webapp configuration
Date Fri, 02 Nov 2001 19:45:15 GMT
I was afraid of that..
I want all of my html served by apache, and anything in /servlet to be
served from tomcat as an app..

I am trying to replace Jrun, and this is how it needs to work for me to be
successful.

Is it possible?



-----Original Message-----
From: Weaver, Scott [mailto:Sweaver@rippe.com]
Sent: Friday, November 02, 2001 1:00 PM
To: 'Tomcat Users List'
Subject: RE: Mod_webapp configuration


Dave,

Tomcat is working correctly.  Just because you have mapped to a WebAppDeploy
URL /servlet does not mean it will invoke a servlet class.  If you want to
be able to do something like this
http://localhost/servlet/vue.web.core.VueWebPageServlet

httpd.conf should look something like this

WebAppConnection conn      warp  localhost:8008
WebAppDeploy     ROOT  conn  /


here is a named vhost example from my httpd.conf.

LoadModule webapp_module modules/mod_webapp.so
AddModule mod_webapp.c 

<VirtualHost *>
    ServerName turbine.scottw
    DocumentRoot "C:/webapps/Apache Tomcat 4.0/webapps/newportal"
    WebAppConnection conn      warp  localhost:8008
    WebAppDeploy     ROOT  conn  /

    <IfModule mod_dir.c>
    	 DirectoryIndex index.html
    </IfModule>
</VirtualHost>


Scott

-----Original Message-----
From: Cracauer, David D. [mailto:dcracauer@vue.com]
Sent: Friday, November 02, 2001 1:48 PM
To: Tomcat Users List (E-mail)
Subject: Mod_webapp configuration


I am trying to setup mod_webapp with apache and can't figure out the config.

I also cannot find any in-depth documentation.
I can access my app directly at
http://localhost:8080/servlet/vue.web.core.VueWebPageServlet

but to get to it through apache I have to use
http://localhost/servlet/servlet/vue.web.core.VueWebPageServlet

here are the relevant lines from my httpd.conf

WebAppConnection conn      warp  localhost:8888
WebAppDeploy ROOT conn /servlet

How can I fix this?
Sorry if this is stupid...

Dave

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message