tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tagunov <tagu...@motor.ru>
Subject [3.3m3][NT4sp6][sun hotspot 1.3.0_01][jni] create (code=10106) error!
Date Sun, 27 May 2001 09:02:43 GMT
Hello, community!

PLEASE, can anybody lend me a helping hand?

The problem:
i'm developing a tool for running tomcat (and
other java apps)
under NT and unix-s. It features control over
environment, directories, logs, it traces
tomcat coming down and brings it up automatically,
it helps in running multiple tomcat instances.
It also manages the sucurity (what user tomcat
is running under and who have access permissions
to start/stop it).(The enviroment borrowes
some code form the Alexandria Java Service,
http://www.alexandriasc.com/software/JavaService/)

The problem: when i run tomcat 3.3m3 under this
environment (i load jvm via JNI JVM_Create..)
and i give a new environment to it (almost
empty). Tomcat fails to start, i attach
a file with stack traces. The problem
comes from java.net.PlainSocketImpp.socketCreate
(Native Method).
I've got sun hotspot 1.3.0_01

The funny thing is that when i
run this from tomcat.bat it starts ok!
(Looks like the same thing happens
when i run it from Alexandria Java Service).

What am i Missing?? Please help! (I'm behind
all deadline with my university project :-(( )

The only difference i can see is passing almost
clean environment to the application.. What do
i need there to make it work?

Will appriciate every bit of help!

Anthony
P.S.  Please, could you cc the copies
to me personally (i do receive list
evry day, but it's so easy to get
lost there..)

P.P.S. If all goes well, my will
be available as open source as APL.

P.P.P.S. One more funny thing: i pass class path to
JVM at creation as -Djava.class.path=...;..;...
when i use sun   hotspot\jvm.dll    it goes okay.
when i use sun   classic\jvm.dll    it does not find my startup.Main
when i use ibm(1.3) classic\jvm.dll it does not fiind my startup.Main
Maybe some ideas on this too?
Mime
View raw message