tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denis Haskin <De...@HaskinFerguson.net>
Subject TC 3.2.1: NoClassDefFoundError when using -Xbootclasspath/a
Date Mon, 05 Nov 2001 20:45:39 GMT
[Tomcat 3.2.1 on Windows 2000]

Apologies if this is a FAQ but I couldn't find anything in the
archives.  I suspected it's similar to the problems people have been
having using EJBs, and the general problems with context class loading
in 3.2.x?

My Tomcat 3.2.1 development instance on Win2K has been working just
fine, but I now need to load a class as a boot class.  This class loads
just fine in a  small standalone test app if I add -Xbootclasspath/a:.
to the command line.

For Tomcat, I put the class file in WEB-INF/classes/java/net and added
the following as an option to the Tomcat run command:

    -Xbootclasspath/a:d:\servlets\WEB-INF\classes

but Tomcat fails to load with:

    Exception in thread "main" java.lang.NoClassDefFoundError:
javax/servlet/http/HttpServlet

Note that my class has nothing to do with
javax.servlet.http.HttpServlet, so I'm pretty puzzled.

Any pointers anyone could provide?  Is there more informaton I could
give that would make this easier to figure out?

Much thanks,

dwh


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message