tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From August Detlefsen <augustd...@yahoo.com>
Subject Webapp configuration
Date Fri, 30 Nov 2001 02:54:43 GMT
I am having trouble configuring my server to run webapps. I am trying
to setup my server (Tomcat 3.2 with Apache 1.3.20 on RedHat 7.1) to
share a webapp, /webmail,  across multiple virtual hosts. 

The webapp runs fine if I access it with lynx from the localhost:

   lynx http://localhost:8080/webmail

But if I try to hit the full URL with IE I only get the source code of
the jsp page. This sounds like a simple configuration issue, but I have
no idea what it is. 

Is there any way to access the webapps without specifying the port
number?

Also, I had to update the tomcat startup script to include the
classpath of the webapps. I thought this was done automatically.. This
is the code I added to tomcat.sh to set the classpaths, maybe it will
be useful to someone: 

# Set classpath for webapps
# add this after the section:
# 'Backdoor classpath setting for development purposes'
# and before: 
# export CLASSPATH
for app in ${TOMCAT_HOME}/webapps/* ; do
  if [ -d ${app}/WEB-INF/lib/ ]; then
  for i in ${app}/WEB-INF/lib/* ; do
    if [ "$CLASSPATH" != "" ]; then
        CLASSPATH=${CLASSPATH}:$i
    else
        CLASSPATH=$i
    fi
  done
  fi
done

Thanks,
-August


__________________________________________________
Do You Yahoo!?
Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.
http://geocities.yahoo.com/ps/info1

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message