tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Reaves <trea...@silverfields.com>
Subject Tomcat+apache=segfault
Date Fri, 09 Nov 2001 20:51:47 GMT
	Hello all.

	I looked over the archive and see where a few other people are having
what looks to be the same problem.  This is my setup:
SuSE 7.1
apache-1.3.19-6 (SuSE)
tomcat4-manual-4.0.1-1 (Jakarta)
tomcat4-4.0.1-1 (Jakarta)
tomcat4-webapps-4.0.1-1 (Jakarta)
mod_webapp-1.0-1  (Jakarta)

I have these three lines in httpd.conf:
LoadModule webapp_module      /usr/lib/apache/mod_webapp.so
WebAppConnection warpConnection warp localhost:8008
WebAppDeploy examples   warpConnection   /examples/

I modified server.xml:

    <!-- Replace "localhost" with what your Apache "ServerName" is set to
-->
    <Engine className="org.apache.catalina.connector.warp.WarpEngine"
     name="gate.silverfields.com" debug="0" appBase="webapps">


That is all the configuration changes I have made.

	I can connecto to apache fine, and I can connect & run servlets & JSPs
from Tomcat.  But when I enter the document /examples/jsp to apache
directly, I get an error that multipul requests have failed.  Two things
are then logged:

in /var/log/httpd/error_log
[Fri Nov  9 19:18:54 2001] [notice] Apache/1.3.19 (Unix)  (SuSE/Linux)
mod_throttle/3.0 mod_layout/1.0 mod_fastcgi/2.2.2 configured -- resuming
normal operations
[Fri Nov  9 19:18:54 2001] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Fri Nov  9 19:21:00 2001] [notice] child pid 4938 exit signal
Segmentation fault (11)
[Fri Nov  9 19:21:00 2001] [notice] child pid 4917 exit signal
Segmentation fault (11)
[Fri Nov  9 19:21:01 2001] [notice] child pid 4952 exit signal
Segmentation fault (11)
[Fri Nov  9 19:21:02 2001] [notice] child pid 4955 exit signal
Segmentation fault (11)
[Fri Nov  9 19:21:02 2001] [notice] child pid 4954 exit signal
Segmentation fault (11)


and in /var/tomcat/logs/apache_log.2001-11-09.txt
2001-11-09 14:20:13
[org.apache.catalina.connector.warp.WarpConfigurationHandler] Filter
mappings (2)
2001-11-09 14:20:13
[org.apache.catalina.connector.warp.WarpConfigurationHandler] Filter
mappings (2)
2001-11-09 14:20:13
[org.apache.catalina.connector.warp.WarpConfigurationHandler] Filter
mappings (2)
2001-11-09 14:20:13
[org.apache.catalina.connector.warp.WarpConfigurationHandler] Filter
mappings (2)
2001-11-09 14:20:14 [org.apache.catalina.connector.warp.WarpConnection]
Exception on socket
java.io.IOException: Premature packet header end
        at
org.apache.catalina.connector.warp.WarpConnection.recv(WarpConnection.java)
        at
org.apache.catalina.connector.warp.WarpRequestHandler.handle(WarpRequestHandler.java)
        at
org.apache.catalina.connector.warp.WarpConnection.run(WarpConnection.java)
        at java.lang.Thread.run(Thread.java:539)

...


	So, that is what is going on.  Anyone know why?  

--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message