tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Burns" <tbu...@67systems.com>
Subject Re: I give up!
Date Sat, 10 Nov 2001 07:44:16 GMT
Pier posted a reply to my inquiry regarding this issue stating that
mod_webapp does not yet support the lack of a trailing '/' character on the
url.
and that their is no time frame for its implementation.

-Tom
Houston, TX

----- Original Message -----
From: "Daniel Seyffer" <tomcat@seyffer.de>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Saturday, November 10, 2001 1:36 AM
Subject: Re: I give up!


> Hello Robert,
>
> Did you also try http://localhost/examples/ ? (notice examples/)
>
> For me "http://localhost/examples" doesn't work, but /examples/ does. I'm
> not sure if this is just a specific problem that I'm facing, (because of
> wrong configuration or whatever) As far as I can see modwebapp (?) doesn't
> seem to be able to "detect" that examples is actually a directory served
by
> tomcat and redirect the user... (?)
>
> ----- Original Message -----
> From: "Robert D. Morse" <rmorse@mdesignz.com>
> To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> Sent: Saturday, November 10, 2001 2:30 AM
> Subject: RE: I give up!
>
>
> > The Invalid Virtual Host name was resolved by uncommenting the
ServerName
> > directive in httpd.conf.
> >
> > Now, trying to go to http://localhost/examples produces a Not Found
error.
> >
> >
> > -----Original Message-----
> > From: Robert D. Morse [mailto:rmorse@mdesignz.com]
> > Sent: Friday, November 09, 2001 5:12 PM
> > To: Tomcat Users List
> > Subject: RE: I give up!
> >
> >
> > Hello Daniel!
> > Thanks for the pointer.  You're correct, the RPM had the wrong directory
> > set, but that didn't fix the immediate problem that I'm facing.  I made
> the
> > changes as outlined by Henri Gomez (see below), however for the webapp
> mods,
> > I now get a warning that the mod_webapp.so module may be compiled with
the
> > wrong flag (I guess this is normal), and a Invalid Virtual Host name at
> the
> >
> > WebAppConnection warpConnection warp localhost:8008
> >
> > line in httpd.conf.
> >
> > So, that's where I'm at with this.  Other suggestions?
> >
> >
> > ===========From Henri=================
> > You have installed tomcat4-4.0.1 rpms :
> >
> >
>
http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0.1/rpms/tomc
> > at4-4.0.1-1.noarch.rpm
> >
>
http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0.1/rpms/tomc
> > at4-webapps-4.0.1-1.noarch.rpm
> >
> > If so you must have tomcat4 running as user tomcat4 and listening
> > on port 8180 at least.
> >
> > Next you should use an Apache modules, which may be mod_jk or
> > mod_webapp.
> >
> > ----------
> > - MOD_JK -
> > ----------
> >
> > use the TC 3.3 mod_jk
> >
> >
>
http://jakarta.apache.org/builds/jakarta-tomcat/release/v3.3/rpms/tomcat-mod
> > -3.3-1.i386.rpm
> >
> > edit /etc/httpd/conf/httpd.conf :
> >
> > --->
> >
> > JkWorkersFile   /etc/httpd/conf/workers.properties
> > JkLogFile   /var/log/httpd/mod_jk.log
> > JkLogLevel   error
> >
> > Alias /examples "/var/tomcat4/webapps/examples"
> > <Directory "/var/tomcat4/webapps/examples">
> >     Options Indexes FollowSymLinks MultiViews
> >     AllowOverride AuthConfig
> >     Order allow,deny
> >     Allow from all
> > </Directory>
> >
> > JkMount /examples/servlet/* ajp13
> > JkMount /examples/*.jsp ajp13
> >
> > <Location "/examples/WEB-INF/">
> >     AllowOverride None
> >     deny from all
> > </Location>
> >
> > Alias /admin "/var/tomcat4/webapps/admin"
> > <Directory "/var/tomcat4/webapps/admin">
> >     Options FollowSymLinks
> > </Directory>
> >
> > JkMount /admin/servlet/* ajp13
> > JkMount /admin/*.jsp ajp13
> >
> > <Location "/admin/WEB-INF/">
> >     AllowOverride None
> >     deny from all
> > </Location>
> >
> > <---
> >
> > Then edit /etc/httpd/conf/workers.properties
> >
> > --->
> >
> > workers.tomcat_home=/var/tomcat4
> > worker.list=ajp13
> >
> > worker.ajp13.port=8109 !!! Nota PORT 8109 !!!
> > worker.ajp13.host=localhost
> > worker.ajp13.type=ajp13
> > worker.ajp13.lbfactor=1
> >
> > <----
> >
> > Verify also the /var/tomcat4/conf/server.xml as Ajp13 enabled
> > and nota THAT we LISTEN on PORT 8109 to avoid collision with
> > running tomcat 3.2 or 3.3 !!!!
> >
> >     <!-- Define an AJP 1.3 Connector on port 8109 -->
> >     <Connector className="org.apache.ajp.tomcat4.Ajp13Connector"
> >                port="8109" minProcessors="5" maxProcessors="75"
> >                acceptCount="10" debug="0"/>
> >
> >
> > Then test and me more :)
> >
> > --------------
> > - MOD_WEBAPP -
> > --------------
> >
> > For mod_webapp use the TC 4.0 mod_webapp (nothing new in 4.0.1)
> >
> >
>
http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0/rpms/mod_we
> > bapp-1.0-1.i386.rpm
> >
> > Edit httpd.conf
> >
> > WebAppConnection warpConnection warp localhost:8008
> > WebAppDeploy ROOT warpConnection /tomcat/
> > WebAppDeploy examples warpConnection /examples/
> >
> > -----Original Message-----
> > From: Daniel Seyffer [mailto:tomcat@seyffer.de]
> > Sent: Friday, November 09, 2001 2:56 PM
> > To: Tomcat Users List
> > Subject: Re: I give up!
> >
> >
> > Hi Robert,
> >
> > In addition to previous comments:
> > Also be sure to check /etc/passwd if the tomcat username and directory
are
> > correctly set to "tomcat4" and not to "tomcat".
> >
> > BTW: I've - more or less - successfully installed Apache 1.3.19 + Tomcat
> > 4.0.1 mod_webapp on RedHat 7.1 using RPMS a few days ago after many
wasted
> > hours of troubleshooting and configuring.
> >
> > Greetings
> > Daniel Seyffer
> >
> > ----- Original Message -----
> > From: "Robert D. Morse" <rmorse@mdesignz.com>
> > To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> > Sent: Friday, November 09, 2001 7:05 PM
> > Subject: I give up!
> >
> >
> > > I'm trying to get Tomcat 4.0.1 and Apache running together under
Redhat
> > > Linux 7.2, and frankly I don't have the time or patience to rummage
> > through
> > > hundreds of e-mail messages, FAQs and How-Tos.  I've managed to get
> prior
> > > versions of Tomcat running, but this one baffles me (and seeing the
over
> > 500
> > > email messages in a few days, I don't think I'm alone).  In any case,
if
> > > anyone is interested in helping, send me e-mail (rmorse@mdesignz.com)
> off
> > > list and we'll work out a consulting arrangement.  We're in So.
> California
> > > so it might be better for someone close to reply.  In turn, I'll pay
> > whoever
> > > helps me get this thing going, and I'll write up some steps for others
> who
> > > are having as much fun as I am.
> > >
> > > Thanks.
> > >
> > >
> > > --
> > > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> > >
> >
> >
> > --
> > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> >
> >
> > --
> > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> >
> >
> > --
> > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> >
>
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>
>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message