tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerry Duhig" <ger...@nectar.demon.co.uk>
Subject Re: cryptography - slow starting????
Date Tue, 13 Nov 2001 21:30:11 GMT
Brilliant - thank you!
----- Original Message -----
From: "Bo Xu" <bo@cybershop.ca>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Tuesday, November 13, 2001 8:23 PM
Subject: Re: cryptography - slow starting????


> ----- Original Message -----
> From: "Gerry Duhig" <gerryd@nectar.demon.co.uk>
> To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>; "David Wall"
> <dwall@Yozons.com>
> Sent: Tuesday, November 13, 2001 1:36 PM
> Subject: Re: cryptography - slow starting????
>
>
> > I guessed as much! How do I force it to happen at startup?
> >
> > Gerry
> >[...]
>
>
> you can put the initialization of cryptography classes in the init(...)
> method of YourServlet, and in the "Servlet-declarition" of
> YourServlet in webapps/yourapp0/WEB-INF/web.xml, you can
> add something like the following:
>         <load-on-startup>1</load-on-startup>
>
> it will ask the container to initialize that "Servlet-declarition" of
> YourServlet
> at the starting-period of container.
>
> you also can use "random seed" to seach in:
> http://www.mail-archive.com/tomcat-user@jakarta.apache.org/
>
>
> haha :-)
> Bo
> Nov.13, 2001
>
>
>
>
> > ----- Original Message -----
> > From: "David Wall" <dwall@Yozons.com>
> > To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> > Sent: Tuesday, November 13, 2001 6:08 PM
> > Subject: Re: cryptography - slow starting????
> >
> >
> > > It's the SecureRandom initialization.  You could just force such an
> > > initialization at startup so that startup has a bit of a slowdown, but
> > then
> > > it runs fast the rest of the time.
> > >
> > > David
> > >
> > >
> > > ----- Original Message -----
> > > From: "Gerry Duhig" <gerryd@nectar.demon.co.uk>
> > > To: <tomcat-user@jakarta.apache.org>
> > > Sent: Tuesday, November 13, 2001 10:02 AM
> > > Subject: cryptography - slow starting????
> > >
> > >
> > > Hi!
> > >
> > > I have successfully built a servlet that uses JCE to encrypt data and
> > > deployed it under JBoss Tomcat 2.4.1-3.2.2.
> > >
> > > The very first access is VERY slow as the cryptography classes do some
> > sort
> > > of initialisation. I don't know what.
> > >
> > > Subsequent actions seem very quick.
> > >
> > > Is this to be expected? Can I speed it up? Can I get this
initialisation
> > to
> > > take place at start-up before a user accesses the servlet?
> > >
> > > Gerry
> > >
> > >
> > >
> > >
> > > --
> > > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> > >
> >
> >
> > --
> > To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> > Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> >
> >
>
>
>
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message