tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Adams" <dad...@magma.ca>
Subject HELP! - Yes...another Tomcat & RMI problem
Date Thu, 01 Nov 2001 14:32:53 GMT
(Yes, I went through the archives, with no luck)
HI,
Which TOMCAT config files need to be edited in order to use RMI. On JRun, I simply provided
Java arguments to point to the stub and added a policy to grant socket access. It had a fluffy
interface, and worked great. Tomcat on the other hand is less intuitive.

I have added a grant line for the sockets to the tomcat.policy file, and added the path to
the stub in the tomcat.sh file. No luck. If I actually include a call to the RMI object, it
hangs tomcat all together, and I must kill the threads manually and then restart it. The call
worked great on JRun/Win2k, but on Linux/Tomcat 3.2.2, all hell breaks lose. Because of this,
I believe that the RMI java code is OK (the fact that it worked on JRun), and that it really
must be a Tomcat config issue.

Please help! I go live Saturday.

- D

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message