tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier NOPRE" <>
Subject Tomcat 4.0.1 + Apache 1.3.22
Date Fri, 02 Nov 2001 10:58:25 GMT
Hi all,

I am desparate. I am trying to install tomcat running under apache. I have
search the WEB but I did not found any complete documentation.

The informations of what I have done are above:
- what is missing or wrong ?
- is the test URL correct ?
- What do I have to start first : apache or tomcat ?
- Do tomcat start the standalone service ?

Thanks for any help


- Windows NT 4
- Apache 1.3.22
- Tomcat 4.0.1
- webapp module downloaded
- libapr.dll and extracted in <apache_home>/apache/modules
- for apache, httpd.conf updated:
    - after "#LoadModule" list, I have added the folowwing line:

LoadModule webapp_module modules/

    - after the "AddModule" list, I have added the folowwing line (without
this line I have an error message):

AddModule   mod_webapp.c

    - after section "<IfModule mod_setenvif.c>", I have added the following

WebAppConnection conn      warp  localhost:8008
WebAppDeploy     examples  conn  /examples
WebAppInfo       /webapp-info

    - I have tried to replace the second line with the following:

WebAppDeploy     examples  conn  "C:\Program Files\Apache Tomcat

- I have changed nothin in the configuration of Tomcat, the file server.xml
containing a section "<Service name="Tomcat-Apache">"
- I start tomcat, the output is :

        Starting service Tomcat-Standalone
        Apache Tomcat/4.0.1
        Starting service Tomcat-Apache
        Apache Tomcat/4.0.1

- I start apache
- I try : http://localhost/ : I get the apache test page
- I try : http://localhost/examples/ : error 404

To unsubscribe:   <>
For additional commands: <>
Troubles with the list: <>

View raw message