tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Goyer" <mgo...@fairtunes.com>
Subject Prob loading mod_webapp on Solaris 8.
Date Tue, 27 Nov 2001 18:07:41 GMT
I've been struggling with this for a week or two now..

I'm able to compile mod_webapp on Solaris 8 with GCC 3.0.1 using the
snapshots of mod_webapp and apr from CVS. However I have to modify my
apxs since three values don't get properly set by the apache makefile.

So I then try and load my compiled mod_webapp with Apache and get the
following error:

Syntax error on line 206 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/mod_webapp.so into server:
ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/mod_webapp.so: symbol __lshrdi3: referenced
symbol not found

I then pulled apart libgcc.a (as recommend in a post here) and made
libgcc.so and located it in /usr/lib and when I do:

export LD_PRELOAD=/usr/lib/libgcc.so
/usr/local/apache/bin/apachectl configtest

I then get:

Syntax error on line 206 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/mod_webapp.so into server:
ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/mod_webapp.so: symbol ap_table_get: referenced
symbol not found

What am I missing?

Can anyone get mod_webapp working on Solaris 8?? If some has.. If you
could post a quick install guide of what you did I'd appreciate that.

Matt


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message