tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From carl...@bookandhammer.com
Subject Re: Apache and Tomcat 4.0.1 on MacOSX 10.1
Date Sun, 11 Nov 2001 05:57:35 GMT
I was able to recompile the source of the webapp module from the nightly 
release of Nov 10th.

However, now when I use the parameters in the main section (not a 
virtual host section)

WebAppConnection conn warp localhost:8080
WebAppDeploy examples conn /examples

I get the following error
[localhost:/usr/sbin] carlson%  apachectl configtest
Syntax error on line 302 of /etc/httpd/httpd.conf:
Invalid virtual host name

I setup  of virtual host with localhost as the name,
I set the main servername to localhost and 127.0.0.1, but I still get 
the same problem.

Any suggestions?

--Peter


On Friday, November 9, 2001, at 05:16 AM, Pier Fumagalli wrote:

>>
>> I am trying to get Tomcat working with Apache on MacOSX 10.1 using the 
>> warp connector.
>> I downloaded and installed version 1.3.22 of Apache and 4.0.1 of 
>> Tomcat.
>> I downloaded the webapp_module.
>> When I check the configuration in apache, I get the following error
>> dyld: /usr/sbin/httpd Undefined symbols:
>> _ap_ctx_get
>> Side Note:
>>   I tried to use the binary for apache and got an error about not 
>> finding the /usr/local/lib/libld.dyld
>>   I looked on the complete filesystem for libld.dyld with no luck.
>
>
> Haha... Someone 's building the HTTPD binaries NOT on a standard OS/X 
> distribution...
>
>
>>   So I compiled apache locally and it works fine without the 
>> webapp_module.
>
>
> Great....
>
>> Any information or thoughts as to why I cannot get the webapp_module 
>> working would be helpful.
>
> >
>
>> I was going to try to compile it locally,  but I couldn't find the 
>> source in the tomcat distribution.
>
>
> Definitely weird since I have it up and running (well, I had it up and 
> running on my OS/X box before I had to bring it back to my old 
> employer, and I still didn't manage to finish to install my PowerBook 
> G4 clean) :)
>
> My OS/X /usr/local is (was) empty, so, that can't be the problem, I 
> believe, though, that I built it against the "default" installation of 
> Apache under OS/X, and that might be your problem...
>
> You can recompile it yourself (I'm _sure_ it works on OS/X :) getting 
> the sources from http://nagoya.apache.org/~pier/
>
> Those are nightly snapshots, so more recent code than the one included 
> in 4.0.1...
>
> 	Pier (loving OS/X)
>


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message