tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rhugga" <tom...@rhugga.net>
Subject Error building Tomcat 4.0.1
Date Tue, 13 Nov 2001 23:44:24 GMT

I am trying to build Tomcat 4.0.1 on Solaris 2..8. I downloaded and
installed all packages listed in BUILDING.txt. I am using j2sdk1_3_1_01 and
j2sdkee1.3.

Here is what I get:
becka:/usr/local/src/Jakarta/jakarta-tomcat-4.0.1-src # ant -projecthelp
Buildfile: build.xml

BUILD FAILED

javax.xml.parsers.FactoryConfigurationError:
java.lang.ClassNotFoundException:
org.apache.crimson.jaxp.SAXParserFactoryImpl
        at
javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:150)
        at
org.apache.tools.ant.ProjectHelper.getParserFactory(ProjectHelper.java:776)
        at org.apache.tools.ant.ProjectHelper.parse(ProjectHelper.java:104)
        at
org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:85)
        at org.apache.tools.ant.Main.runBuild(Main.java:439)
        at org.apache.tools.ant.Main.start(Main.java:153)
        at org.apache.tools.ant.Main.main(Main.java:176)

Total time: 1 second
java.lang.ClassNotFoundException:
org.apache.crimson.jaxp.SAXParserFactoryImpl

I have jaxp installed into /usr/local/jaxp-1.1 and the build.properties file
reflects this. I verified that jaxp.jar is indeed at this location. For the
hell of it I unpacked jaxp.jar and verified that this class was included in
the jar file. I have included /usr/local/jaxp-1.1 in my CLASSPATH.

What am I missing?

Thanks,
Chuck



--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message