tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "robin" <ro...@sublime.org>
Subject LinkageError running 4.0.1 on IBM 1.3.0 VM
Date Mon, 19 Nov 2001 18:09:47 GMT
Hi,

I'm trying to run Tomcat 4.0.1 under the IBM JVM 1.3.0.  If I start by unpacking the archive,
and then use the startup.sh script, after setting my path and unsetting my classpath I get
the following output from the scripts:

Starting...
Using CLASSPATH:     /usr/local/jakarta-tomcat//bin/bootstrap.jar
Using CATALINA_BASE: /usr/local/jakarta-tomcat/
Using CATALINA_HOME: /usr/local/jakarta-tomcat/
Using JAVA_HOME:     /usr/local/IBMJava2-13/jre/


This seems healthy enough, but logs/catalina.out contains:

Catalina.start: LifecycleException:  start: :  java.lang.LinkageError: Class java/net/URL
violates loader constraints
LifecycleException:  start: :  java.lang.LinkageError: Class java/net/URL violates loader
constraints
        at java.lang.Throwable.<init>(Throwable.java:84)
        at java.lang.Exception.<init>(Exception.java:35)
        at org.apache.catalina.LifecycleException.<init>(LifecycleException.java:126)
        at org.apache.catalina.loader.WebappLoader.start(WebappLoader.java:641)

[ etc. etc. ]

Which is decidedly less healthy, and the server won't respond to any requests.

I tried the same thing using sun's jdk 1.2.2, and got:

Starting...
Using CLASSPATH:     /usr/local/jakarta-tomcat//bin/bootstrap.jar:/usr/local/jdk1.2.2//lib/tools.jar
Using CATALINA_BASE: /usr/local/jakarta-tomcat/
Using CATALINA_HOME: /usr/local/jakarta-tomcat/
Using JAVA_HOME:     /usr/local/jdk1.2.2/


from the script, and a working server.

The platform is linux 2.2.12-20 on a PIII.

After I hit this problem, I tried building from source under the IBM jvm, mainly to see whether
it would throw up anything useful.  I hit on a 'sealing violation' right at the beginning
of the build, in ANT, and this reproduced on the sun jvm .  I am aware that this means that
there are more than one jar containing members of a package and at least one of them is sealed.
 I tried clearing the classpath altogether, but got the same problem.  In any case - all I
want is a binary version which works with the IBM vm.

Am I doing something obviously wrong?

Thanks.

-Robin Barooah

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message