tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Casto" <rob...@cincijava.com>
Subject RE: Launching subprocess under Tomcat as a Service
Date Fri, 26 Oct 2001 03:28:53 GMT
Some very good suggestions. I will give them a try. Thanks.

Robert Casto

.........................................................
 CinciJava | Java Development and Training

Robert Casto | robert@cincijava.com
513-349-JAVA | www.cincijava.com

-----Original Message-----
From: Frank Lawlor [mailto:frank.lawlor@athensgroup.com]
Sent: Thursday, October 25, 2001 1:31 PM
To: Tomcat (E-mail)
Subject: Re: Launching subprocess under Tomcat as a Service

You should try to figure out what it is hanging on.
Add some tracing.

You can launch a subprocess, but it is running as the
service user in a service environment.  This is VERY
likely different from your non-service environment.

To help debug:
  - print out the path to a file
  - print out the classpath ...
  - print out the env ...
  - remember that services are usually set to NOT be able
    to interact with the desktop.  Try changing it to yes.
  - remember that it may have different permissions so
    it might not have access to resources that you do.
  - remember that you cannot access mounted drives

Frank Lawlor
Athens Group, Inc.
(512) 345-0600 x151
Athens Group, an employee-owned consulting firm integrating technology
strategy and software solutions.






Mime
View raw message