tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Esposito" <dvespos...@newnetco.com>
Subject mod_jk won't start "Error while opening the workers"
Date Wed, 10 Oct 2001 22:02:46 GMT
Howdy all ...

I'm having the strangest problem ... I have had mod_jk (apache connecting to
tomcat) working for the past 2 or 3 months ... however, when i restarted
Apache today, mysteriously i could not get it to restart ...

Platform:
Redhat 7.0
Apache/1.3.12

Here's what I know:

Apache normally will start with or without Tomcat being up ... So most of my
following tests have been without tomcat up ...

I have commented out everything in my httpd.conf related to mod_jk ... When
I do that, Apache starts just fine ...

When I uncomment JUST the "LoadModule" line, I get the following error (in
error_log):
[emerg] (38)Function not implemented: Error while opening the workers

When I uncomment the "LoadModule", "AddModule" and "JKWorkersFile" lines, I
get the following error:
[emerg] (2)No such file or directory: Error while opening the workers

This is the relevant section of my httpd.conf:
LoadModule jk_module modules/mod_jk.so
AddModule mod_jk.c
JkWorkersFile /export/programs/tomcat/conf/workers.properties

So, I've checked and, sure enough, my "workers.properties" exists at that
location ... I've checked the permissions on my mod_jk.so file to make sure
it was the same as all of the other .so files in the modules directory ...
I've tried copying mod_jk.so from a different server to make sure that it
wasn't corrupted ... I've rebooted the server a half dozen times ... I've
shut off just about every other process that I could to make sure nothing
was conflicting ... I've tried adding a JkLogFile directive to httpd.conf to
see if I could get some logging out of the module itself ... nothing was
generated ...

To repeat: this all worked fine about 3 hours ago ... (and it had been
working for the past few months) ... so we're not talking about getting
things setup for the first time ...

Please, someone, say you know what is going on ... ;) ... tell me what to
try ... I have exhausted everything in the book ... next on the list will be
to upgrade apache to see if the problem goes away ... but that is really a
last resort ...

Thanks in advance

-Dave


Mime
View raw message