tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vernon Wu" <v...@hotmail.com>
Subject Re: Is Tomcat 4.0 Backward Compatible with 3.2.3 App??
Date Thu, 25 Oct 2001 20:11:21 GMT
We run into the compatible problem in our one module of servlet/JSP
application. A few months ago, I implemented it using the 3.x version of
Tomcat. After the 4.x version was stable, I had tried to move it over to the
Tomcat 4 for a better performence. The problem we run into is an exception
on a serializable from the DB access utility. The non-standard DB access
utility is from IBM, Informix formerly. We had reported this problem on the
support mailing list for more than a month, not response yet. I don't know
whether the problem is related with the Servlet/JSP spec or not. I would
like to know the cause.

Thanks in advance.

v.
----- Original Message -----
From: "Craig R. McClanahan" <craigmcc@apache.org>
To: <tomcat-user@jakarta.apache.org>
Sent: Tuesday, September 25, 2001 1:27 PM
Subject: Re: Is Tomcat 4.0 Backward Compatible with 3.2.3 App??


>
>
> On Tue, 25 Sep 2001 ewright@vividsolutions.com wrote:
>
> > Date: Tue, 25 Sep 2001 09:53:26 -0700
> > From: ewright@vividsolutions.com
> > Reply-To: tomcat-user@jakarta.apache.org
> > To: tomcat-user@jakarta.apache.org
> > Subject: Is Tomcat 4.0 Backward Compatible with 3.2.3 App??
> >
> > How backward compatible is Tomcat 4.0?
> >
> > I have an application that I developed with tomcat 3.2 and deployed on
> > JRun 3.0. Since then I have installed the final 4.0 and now have some
> > changes to make to my application and I am getting all kinds of errors
> > using the same .WAR file.
> >
> > I have re-installed 3.2.3 to make sure that I did not screw up a config
file
> > or something else and it works fine. Is there something that I missed
> > where I have to do a conversion on my older apps to use them in Tomcat
4.0?
> >
>
> If an application that works on Tomcat 3.2.3 meets the following criteria,
> it should run unchanged on Tomcat 4.0:
>
> * Compliant with the Servlet 2.2 and JSP 1.1 specs
>
> * Does not rely on bugs in Tomcat 3.2.3 that have been fixed in 4.0
>
> * Does not rely on non-specification-related behavior that might
>   have changed in 4.0
>
> Failure to run is a bug in 4.0 if all these criteria are met.  By far the
> most common problem people have is web.xml files that have elements not
> conforming to the DTD requirements (which violates the first requirement
> above) -- Tomcat 3.2.3 accepted such web.xml files anyway, but Tomcat 4.0
> will not.
>
> > Thanks
> >
> > Eric Wright, Programmer / Analyst
> > Vivid Solutions Inc.
> > INTERNET : ewright@VividSolutions.com
>
> Craig
>
>
>

Mime
View raw message