tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pier Fumagalli <p...@betaversion.org>
Subject Re: MOD_WEBAPP & Gzip'ed or Object Streams, Error: Invalid WARP packet type for body
Date Fri, 19 Oct 2001 16:14:59 GMT
Philippe Khalife at pkhalife@dinmar.com wrote:

> 
> This is what I'm running.
> 
> TC4,
> Apache1.3.22
> Mod_webapp
> 
> I'm having the same problem on Solaris, Linux, and Win2000
> 
> I have Servlet that produces output that is either HTML and browser bound or
> to communicate with an Applet using Object input/output streams and it works
> fine using a gzip'd stream as well, but under the HttpConnector only
> 
> Under the Warp Connector,  Servlet->Browser Works fine if the output is
> gzip'd or not.
> 
> But Servlet->Applet does not, I was getting errors that the stream is
> missing the required headers for Gzip to work.
> So I disabled the gzip'd stream, the application moves a little further but
> Catalina is throwing this error:
> 
> java.io.IOException: Invalid WARP packet type for body
>       at
> org.apache.catalina.connector.warp.WarpRequest$Stream.read(Unknown So
> urce)
>       at
> org.apache.catalina.connector.warp.WarpRequest$Stream.read(Unknown So
> urce)
>       at org.apache.catalina.connector.RequestStream.read(Unknown Source)
>       at org.apache.catalina.connector.RequestStream.close(Unknown Source)
>       at java.io.ObjectInputStream.close(ObjectInputStream.java:1874)
> .....
> 
> If anyone has seen this before, or knows what it might be I would really
> appreciate your response.

I'm fixing it right now (see this bug entry in the database):
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3534

I found a way to reproduce it, and it is not looking that hard... Should be
fixed in the next daily snapshot..

    Pier


Mime
View raw message