tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Knights" <brett.knig...@tanner.com>
Subject RE: Driver fails to load on two webapps
Date Thu, 04 Oct 2001 16:57:08 GMT
>
> Might i try moving the jar to WEB-INF\classes instead of WEB-INF\lib ?

Wouldn't work. Jars are only loaded from the lib directory.


As you did I ended up with my driver jar file in a common directory
(lib/common for tc3.3)
I have a connection pool manager (bitmechanic) and I keep its jar in the
WEB-INF/lib file for my web apps.

Everything seems to work properly.

It's odd that the everything-in-its-webapp-lib-directory approach doesn't
work though.
The DriverManager is supposed to be ClassLoader aware. What happens when you
call DriverManager.getDriver(url) from a simple servlet in each webapp? What
about calling DriverManager.registerDriver() in a load-on-startup servlet in
each webapp?

hth

> -----Original Message-----
> From: Brian Richards [mailto:ncmusic@pobox.com]
> Sent: Thursday, October 04, 2001 6:52 AM
> To: tomcat-user@jakarta.apache.org
> Subject: Re: Driver fails to load on two webapps
>
>
> Yes all the classes are in the correct place I sent another
> email saying
> that I solved the problem by putting the db2java.jar ONLY in
> TOMCAT_HOME\lib
> instead of WEB-INF lib for each webapp.  This takes care of
> the problem.
> The other think Ought to mention is that they both work fine
> seperately as
> long as it's the webapp loaded before the other one.
>
> -brian




Mime
View raw message