tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Knights" <brett.knig...@tanner.com>
Subject RE: Driver fails to load on two webapps
Date Thu, 04 Oct 2001 14:51:40 GMT
Sorry, I hadn't read your subsequent post.

Are you using a connection pool? If so what happens when you try to use
connections where you try to connect from each web app as a different user?

Also what do you see when you set a LogWriter for the DriverManager? It
should show you the drivers that it tries to load for each getConnection
request. That may help.

> -----Original Message-----
> From: Brett Knights [mailto:brett.knights@tanner.com]
> Sent: Thursday, October 04, 2001 6:13 AM
> To: tomcat-user@jakarta.apache.org
> Subject: RE: Driver fails to load on two webapps
>
>
> Are all the sql related class files for each webapp in the respective
> webapps lib or classes directories?
>
> If not you might try that. (And if it works please report back.)
>
> HTH
>
> > -----Original Message-----
> > From: Brian Richards [mailto:ncmusic@pobox.com]
> > Sent: Wednesday, October 03, 2001 9:54 PM
> > To: tomcat-user@jakarta.apache.org
> > Subject: Driver fails to load on two webapps
> >
> >
> > Ok I am running two applications that use the IBM DB2
> > appdriver to connect
> > to two different databases.  The problem is this when i start
> > up tomcat only
> > one of the applications can access the database.  The first
> > one to have a
> > request made wins and the other app gets a No Suitable Driver
> > exception.
> > They both work independtly as long as it's the first one
> > requested.  My
> > theory is that the Class.forName(driver) being called twice
> is mucking
> > things up the code at fault is:



Mime
View raw message