tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reynir Hübner <>
Subject RE: Running Tomcat as a service on win2k
Date Wed, 10 Oct 2001 14:38:46 GMT
one thing you have to look out for :

have all jar files your web-app dependes on(your / 3rd party jar files),
in your webapp /lib directory.
It is not enough to have those in the tomcat/lib directory.

I dont know why, (it´s probalby a "bug"). I had a similar problem once,
moved the jar files from the tomcat lib into mywebapp lib and it runs ok

hope it helps

-----Original Message-----
From: Tarek M. Nabil []
Sent: 10. október 2001 14:18
Subject: RE: Running Tomcat as a service on win2k

I'm sorry to say that my happiness didn't last for long. Tomcat dies
after the first request, I checked the log files, and I found this error
in mod_jk.log...

[jk_connect.c (143)]: jk_open_socket, connect() failed errno = 61
[jk_ajp12_worker.c (152)]: In jk_endpoint_t::service, Error sd = -1

I checked the archives and it says that this error is connection refused
and it's caused when the port specified for ajp12 in workers.porperties
is different from the one in server.xml. I check this out, and they are
the same (I never changed anything in those files). Is there any other
reason this is happening?

Tarek Nabil

-----Original Message-----
From: Tarek M. Nabil 
Sent: Wednesday, October 10, 2001 2:02 PM
Subject: RE: Running Tomcat as a service on win2k

According to the use of jk_nt_service.exe, it should be used with either
a -i or a -r flag. When I use it with a -i flag, the service is
installed successfully, but then fails to start with netstart. Without
the -i flag, it gives the following error..

Asked (and given) winsock 1.1
Error: StartServiceCtrlDispatcher failed.

but I think that's caused by improper usage, cause you have to specify
one of the two flags.

If I try to run tomcat on it's own, it does run successfully. It also
works fine with Apache. The only thing that I can't do is make it run as
a service.

I'm not using spaces in the specification of the javahome....I wrote the
following line in


As for the tomcat home, I wrote.


You know what, while I was writing this email I tried out something and
it worked, can you imagine, the single quotes are the reason the service
doesn't wanna start, woow :)

Brian and David, thanks a million :))

Tarek Nabil

-----Original Message-----
From: Brian Richards []
Sent: Tuesday, October 09, 2001 11:04 PM
Subject: Re: Running Tomcat as a service on win2k

did you try running jk_ntserver <service name> on the command line
of using net start?
does tomcat run by itself? is it integrated with apache or anything

----- Original Message -----
From: "Tarek M. Nabil" <>
To: "Tomcat-User (E-mail)" <>
Sent: Tuesday, October 09, 2001 10:19 AM
Subject: Running Tomcat as a service on win2k

I've been trying to get Tomcat to run as a service on win2k
professional, but it's not working. I install the service and modify the file and when I try to start the service, it doesn't
start. The problem is, it doesn't return any errors, it simply doesn't
start. I thought the problem might be with the jdk1.3, so I tried 1.2.2
and still, nothing's changed.

Any ideas?


Tarek Nabil

View raw message